Welcome to Geeklog Monday, October 14 2019 @ 09:08 pm EDT

Geeklog Forums

Professional css not loading / errors


Rageriot

Anonymous
I've been trying to used the latest version of the professional theme to personalise my sites look but I get error calls on various pages such as this example i see when going to the admin config page

PHP Formatted Code
An error has occurred:

(This text is only displayed to users in the group 'Root')

256 - Template Error: filename: file /homepages/25/d406865630/htdocs/html/layout/professional_css/noscript.thtml does not exist. @ /homepages/25/d406865630/htdocs/glfiles/system/classes/template.class.php line 992

array(1) {
  ["msg"]=>
  string(106) "filename: file /homepages/25/d406865630/htdocs/html/layout/professional_css/noscript.thtml does not exist."
}
 


these files of course dont exist but why would they be missing?

I did try copying professional_css contents to the original gl professional folder to merge it and this appaeard to work but the admin page for example was blan with the site blocks around it.

thanks

RageRiot

Status: offline

RageRiot

Forum User
Newbie
Registered: 11/03/12
Posts: 3
looks like I didnt login althought I thought i had done because I went to the login screen

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
As the error message suggests, make sure there's a file noscript.thtml in your professional_css directory (and that it is readable by the webserver).

bye, Dirk

Status: offline

RageRiot

Forum User
Newbie
Registered: 11/03/12
Posts: 3
that was my point, that the files are not in the package to begin with. I assumed the absence of them files was due to the theme being recoded in CSS.

are these thtml files meant to be generic because I took noscript.thtml from the default gl 1.8.1 download and loaded the same page up, this time no error but the site isnt built correctly and the admins pages are blank(the block topics, admin only, user functions,.. are visable on the lest with no style)

I'll get an img when I get a chance if needed to describe better what I see.

thanks

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
professional_css theme is not part of the geeklog 1.8.1 download. It is a third party theme from user/contributor ivy.
It does look like noscript.thtml is not included with the theme, maybe ivy can clear up what should be included in the file.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

Roccivic

Forum User
Moderator
Registered: 19/05/10
Posts: 136
The professional_css theme is available in our mercurial repository. You could get the right version of this theme by cloning the repository, checking out the tag that refers to your version of Geeklog and then copying the theme folder over to your installation.

Rouslan

Status: offline

RageRiot

Forum User
Newbie
Registered: 11/03/12
Posts: 3
thank you. that did the trick Smile just need to fiddle with the css template now Big Grin

All times are EDT. The time is now 09:08 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content