Welcome to Geeklog Tuesday, October 22 2019 @ 01:48 am EDT

Geeklog Forums

Themes inoperable in GLv1.8.1


Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Subject says it all. For some season Theme config sees and allows me to select and save different themes but my site only displays as if Professional is selected.

Any help would be appreciated.

Thanks, Bob

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Same answer as over here: There are 2 settings for the theme, one in Configuration and one in My Account. And the latter overrides the former.

bye, Dirk

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Yeah, I'm a dumba$$. I saw that after I posted my question (in the wrong place) Thanks, and Sorry.

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
OK, so I disabled user themes, installed and selected an old theme from a GL 1.5 install and refreshed. Now getting errors when I try to access Configuration or edit User Settings.

Specifically:

256 - Template Error: filename: file /path to/public_html/layout/south_jersey_tournaments/admin/user/password.thtml does not exist. @ /path to/system/classes/template.class.php line 992

array(1) {
["msg"]=>
string(113) "filename: file /path to/public_html/layout/south_jersey_tournaments/admin/user/password.thtml does not exist."
}

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
There were theme changes since 1.5.0, which are partially documented (we didn't really do a good job documenting the changes in 1.8.0, I have to admit).

If files are missing (like in this case), simply copy them over from the Professional theme.

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
You can also find updated themes on our demo site. Depending on how much you modified yours, this may safe you some work.

bye, Dirk

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Thanks, fairly extensive mods (for me at least). Would prefer to fix this one if possible.

You file copy advice worked perfectly for repairing access to My Account and User Edits. Just had to grab about 6-8 files.

Having strange prob when selecting Configuration. Config Sections and Geeklog Config menus appear but none work. I just get the included image in the main text area.


Any clues? (I may well end up working with one of your demo site themes. Things seem to work best for me when I follow your advice.)

Thanks

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
1.8.0 changed how the JavaScript code is loaded. Part of it is now loaded in the site's footer instead of the header - that's actually a bit that we did document (see above). Compare your site's header.thtml and footer.thtml with the ones from the Professional theme. Specifically watch out for the plg_footercode variable.

bye, Dirk

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Roger that. I'll review. Thanks for helping an amateur.

~Bob

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
For the configuration to work you would need the jquery_ui directory in your theme directory as well.

To be on the safe side I would copy from the professional theme directory to your themes directory the admin, jquery_ui and tooltips directories as well as do the changes Dirk suggests in the header and the footer.

Tom
One of the Geeklog Core Developers.

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Thanks for the input. I duplicated the Professional theme and used it as a basis for my new one. Problem solved.

Thanks gentlemen,
~Bob

All times are EDT. The time is now 01:48 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content