Welcome to Geeklog Tuesday, February 18 2020 @ 07:21 pm EST

Geeklog Forums

Windows Live Writer


Status: offline

DanGarion

Forum User
Newbie
Registered: 13/10/04
Posts: 12
Hi,

I was wondering if anyone has attempted or tried to get Windows Live Writer to work with Geeklog? I was messing with it but can't figure it out yet, it works with my Wordpress sites, but there is no built in geeklog functionality.

Here is info on their API.
http://msdn2.microsoft.com/en-us/library/bb463266.aspx
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Geeklog doesn't have a webservices API yet, so that would require quite a bit of code to get working (it should be doable but it won't be pretty).

bye, Dirk
 Quote

Status: offline

DanGarion

Forum User
Newbie
Registered: 13/10/04
Posts: 12
Quote by: Dirk

Geeklog doesn't have a webservices API yet, so that would require quite a bit of code to get working (it should be doable but it won't be pretty).

bye, Dirk


Thanks Dirk,

Yeah I've used the blog plugin with hit or miss results, so I was hoping I'd get better performance using WLW. I'm in no hurry, but it's good to know that it's possible.

Thanks for the always prompt replies. :pray:
 Quote

Status: offline

nightshadow

Forum User
Newbie
Registered: 19/12/04
Posts: 8
Location:Brisbane, AU
Unfortunately the blogger API does not work.. in that the client doesn't support blogger API (only blogger directly).
It is frustrating as the WLW client supports wordpress API, metaweblog API etc and a few others - just not bloggerAPI in the format the plugin uses.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
WLW supports the Atom Publishing Protocol, though, which will be supported by Geeklog 1.5.

bye, Dirk
 Quote

Status: offline

haakuturi

Forum User
Newbie
Registered: 10/02/09
Posts: 3
It works!

Only problem is that I can't figure out how to get images uploaded via FTP with WLW/Geeklog... Here's the error message:
PHP Formatted Code

System.NullReferenceException: Object reference not set to an instance of an object.
   at WindowsLive.Writer.BlogClient.Clients.AtomClient.NewPost(String blogId, BlogPost post, INewCategoryContext newCategoryContext, Boolean publish, String& etag, XmlDocument& remotePost)
   at WindowsLive.Writer.BlogClient.Blog.NewPost(BlogPost post, INewCategoryContext newCategoryContext, Boolean publish)
   at WindowsLive.Writer.PostEditor.UpdateWeblogAsyncOperation.DoWork()
   at WindowsLive.Writer.CoreServices.AsyncOperation.InternalStart()
 
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Geeklog's implementation of AtomPub doesn't support images ("media resources", as the AtomPub specification calls them). So I'm afraid you will have to upload images separately.

bye, Dirk
 Quote

All times are EST. The time is now 07:21 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content