Welcome to Geeklog, Anonymous Thursday, February 02 2023 @ 04:15 pm EST

Geeklog Forums

Problem in Forum 2.0 - Can\'t submit topics to the forum...


Status: offline

jalmada

Forum User
Newbie
Registered: 07/23/03
Posts: 12
Location:Northern California
Hello, I am running Geeklog 1.3.7 with the security patches (Yes, I know I need to upgrade), but I went ahead and installed the Forum 2.0 - very slick package and pretty simple to install/configure. Aside from the fact that I\'m slogging through getting the style sheets to work with the Spring Midnight theme, I\'m having an annoying problem that has stopped me cold. I can preview posts to topics, but every time I say to submit the topic, I get the following error: \"Error! Not all required fields were completed or were too short in length.\" Now, I believe I\'ve traced the code in the createtopic.php file to: --------------------------------------------------------------------------- // ADD TOPIC if ($submit == $LANG_GF01[\'SUBMIT\']) { $date = time(); if($method == \"newtopic\") { if($aname != \'\') { $name = $aname; } if(strlen($name) > 2 && strlen($subject) > 1 && strlen($comment) > 1) { --------------------------------------------------------------------------- The last line seems pretty stock to me - check the lengths and do our thing or kick an error message - trouble is that things look great in the code and I\'m filling out the form correctly, so what gives here? Any advice would be appreciated! Jon
Jon F. Almada
 Quote

HarshReality

Anonymous
Check you username.... if you'll notice the username has to be GREATER than 2 characters in length.
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 10/20/03
Posts: 807
Also, use Forum 2.2RC1. Don't use 2.0
 Quote

All times are EST. The time is now 04:15 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content