Welcome to Geeklog Tuesday, June 25 2019 @ 09:44 pm EDT

Geeklog Forums

2 errors


Loon

Anonymous
freakingout
Warning: main(/public_html/system/databases/mysql.class.php) [function.main]: failed to create stream: No such file or directory in /home/looniste/public_html/system/lib-database.php on line 110 Fatal error: main() [function.main]: Failed opening required \'/public_html/system/databases/mysql.class.php\' (include_path=\'\') in /home/looniste/public_html/system/lib-database.php on line 110
How can I fix these two problems? Confused

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Your $_CONF['path'] is not correct. It has to be an absolute path, i.e. in your case, it needs to start with /home/looniste

bye, Dirk

Loon

Anonymous
1050: Table \'gl_access\' already exists
Now I get that error.. Confused

Loon

Anonymous
I get that error after step 2 of 2.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
That's because you already ran the installation script once and Geeklog already created the tables (or at least some of them). To be on the save side, drop the database and run the installation again.

bye, Dirk

Loon

Anonymous
Now I get this:
Template Error: set_root: /home/looniste/public_html//home/looniste/public_html/layout/XSilver is not a directory. Halted.
Cry

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Well, obviously your paths still aren't correct. I'd say you did change $_CONF['path_html'] even though you didn't need to. Try the original setting, i.e.

$_CONF['path_html'] = $_CONF['path'] . 'public_html/';

bye, Dirk

Loon

Anonymous
Okay, GeekLog is now installed..I dunno if you wan\'t me to make a new thread for this since it\'s post-installation. Over the \"Welcome to Geeklog!\" article I get:
Warning: fopen(/home/looniste/public_html/logs/error.log) [function.fopen]: failed to create stream: Permission denied in /home/looniste/public_html/blankweb/lib-common.php on line 1555 Today\'s Featured Article

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
You didn't do the chmods properly. Please read that section in the installation instructions again, specifically the bit about chmod'ing the files IN the directories, too.

There's also a script to test the file and directory permissions (also mentioned in the installation instruction) - use it.

bye, Dirk

All times are EDT. The time is now 09:44 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content