Subject: 2 errors

Posted on: 30/06/03 01:29pm
By: Anonymous

Warning: main(/public_html/system/databases/mysql.class.php) [function.main]: failed to create stream: No such file or directory in /home/looniste/public_html/system/lib-database.php on line 110 Fatal error: main() [function.main]: Failed opening required \'/public_html/system/databases/mysql.class.php\' (include_path=\'\') in /home/looniste/public_html/system/lib-database.php on line 110
How can I fix these two problems? Confused

Re:2 errors

Posted on: 30/06/03 01:39pm
By: Dirk

Your $_CONF['path'] is not correct. It has to be an absolute path, i.e. in your case, it needs to start with /home/looniste

bye, Dirk

Re:2 errors

Posted on: 30/06/03 02:25pm
By: Anonymous

1050: Table \'gl_access\' already exists
Now I get that error.. Confused

Re:2 errors

Posted on: 30/06/03 02:26pm
By: Anonymous

I get that error after step 2 of 2.

Re:2 errors

Posted on: 30/06/03 02:34pm
By: Dirk

That's because you already ran the installation script once and Geeklog already created the tables (or at least some of them). To be on the save side, drop the database and run the installation again.

bye, Dirk

Re:2 errors

Posted on: 30/06/03 02:38pm
By: Anonymous

Now I get this:
Template Error: set_root: /home/looniste/public_html//home/looniste/public_html/layout/XSilver is not a directory. Halted.
Cry

Re:2 errors

Posted on: 30/06/03 02:42pm
By: Dirk

Well, obviously your paths still aren't correct. I'd say you did change $_CONF['path_html'] even though you didn't need to. Try the original setting, i.e.

$_CONF['path_html'] = $_CONF['path'] . 'public_html/';

bye, Dirk

Re:2 errors

Posted on: 30/06/03 02:51pm
By: Anonymous

Okay, GeekLog is now installed..I dunno if you wan\'t me to make a new thread for this since it\'s post-installation. Over the \"Welcome to Geeklog!\" article I get:
Warning: fopen(/home/looniste/public_html/logs/error.log) [function.fopen]: failed to create stream: Permission denied in /home/looniste/public_html/blankweb/lib-common.php on line 1555 Today\'s Featured Article

Re:2 errors

Posted on: 30/06/03 03:06pm
By: Dirk

You didn't do the chmods properly. Please read that section in the installation instructions again, specifically the bit about chmod'ing the files IN the directories, too.

There's also a script to test the file and directory permissions (also mentioned in the installation instruction) - use it.

bye, Dirk

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=19664