Welcome to Geeklog, Anonymous Saturday, October 01 2022 @ 10:37 am EDT

Geeklog Forums

Showing Block to Guests/Anonymous Only


Anonymous

Anonymous
So I thought this was pretty straight forward. I created a block and unchecked all the permissions except R for Anonymous. The result is the Anonymous user (user not logged in) can't see the block but others can. What the heck?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Works for me ... Btw, members of the Root group (e.g. the Admin user) will still see the block since they have access to everything. bye, Dirk
 Quote

Anonymous

Anonymous
Hmm, I am definatley not getting the same results. I created a block, which is basically a little html. I unchecked everything except for R under the 'anonymous' I set the block to Topic ALL and Side Right, Type Normal. (1)Logged on as a regular user it does not show. (2)Not logged on to the site, presumably anonymous, it does not show. (3)Logged on as root it does show. Now results 1 and 3 are ok, but what is up with result #2?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Hmm, okay, found it: It's the group setting for the block that makes the difference. I would assume your block belongs to the group "All Users"? Since anonymous users are also in that group, Geeklog uses the group permissions - which you set to "none", so the block does not display. Choose another group (any that Anonymous does not belong to) and it should work as expected. Now we only need to figure out whether this is a bug or a feature ;-) bye, Dirk
 Quote

Anonymous

Anonymous
Worked Great Dirk! I think it is a Featured Bug!
 Quote

All times are EDT. The time is now 10:37 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content