Welcome to Geeklog, Anonymous Tuesday, April 16 2024 @ 12:21 pm EDT

Geeklog Forums

SQL Problem


Anonymous

Anonymous
Alright, so, here is the deal. I installed Gl for my site, after going though a number of PHP Portal systems and find that Gl was the best. Now, I uploaded it and installed it, and it worked fine for about a week or two, then, I log in as the Admin on my site, and I try to edit/and/or/contribute a story, and I get this error: 1064: You have an error in your SQL syntax near '' at line 1 And, quite frankly, I have no idea what that means. If someone could help me out on how to fix it, it would be great! Thanks. _MicroBurn_
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Please quote the corresponding line from Geeklog's error.log file since that will include the actual SQL request that caused the error. Without that information, it's almost impossible to say what's happening ... bye, Dirk
 Quote

Status: offline

uffda

Forum User
Newbie
Registered: 10/21/02
Posts: 6
I too see this problem every once in a while... I usually have to delete the local cookie file to get things working gain.
 Quote

Anonymous

Anonymous
Turns out konqueror decided it wanted to be an idiot, and kept give me that error, Everything with Mozilla went just fine!
 Quote

Status: offline

SuRF3R

Forum User
Newbie
Registered: 01/05/03
Posts: 1
i get the same problem sometimes here is the corresponding line from the logfile: 1/5/2003 1:54:53 PM - 1064: You have an error in your SQL syntax near '' at line 1 SQL in question: SELECT username FROM gl_users WHERE uid = as i have no idea on what it is, i hope someone can help me with it
 Quote

Anonymous

Anonymous
did you all figure this out? what was it? i see one person said it was fine with mozilla -- is that the general answer? browser trouble?
 Quote

Oliver

Anonymous
I just started getting this error. And nothing seems to make it better.
An anonymous user cannot post a new story without getting this error.
I get it with Firefox and IE. Clearing caches etc does not help.
It appeared after upgrading to 1.3.11 (from 1.3.9rc2).

The problem seems to be that geeklog thinks the anonymous user is a regular user and tries to fetch the username of a non-existant uid. But since $A["uid"] is empty, and an error is returned. This is in admin/story.php, line 309.

Since I have no idea what the call tree is, it's difficult to backtrack.
 Quote

Oliver

Anonymous
happy
Quote by Oliver:The problem seems to be that geeklog thinks the anonymous user is a regular user and tries to fetch the username of a non-existant uid.


I think I solved my version of this issue.

I had added "Anonymous" to most groups. At least to the Story Admin and Topic Admin groups. Apparently this caused geeklog to think that an anonymous user was a real user and tried to fetch his full name.

When I removed the Anonymous user from all but the "All Users"-groups the anonymous posting started to work again. (Removing it from All Users will give the same error when trying to load any page as an anonymous user).

The thing is, the user "Anonymous" does not show up in the _assigned_ group edit lists. So it wasn't apparent if it's even modifyable. It does show up in the available users -list, which is where I picked it up the first time. (I was adding a bunch of rights to all users)

So I had to use:
delete from gl_group_assignments where ug_uid=1 and ug_main_grp_id <> 2

ug_uid=1 is the anonymous user id.

Works now.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Oliver: I had added "Anonymous" to most groups. At least to the Story Admin and Topic Admin groups.

Ouch. Why would you want to do such a thing? If it had worked, that would have enabled any person visiting your site to edit stories.

Besides, how did you even manage to do that? Geeklog shouldn't let you do it.

bye, Dirk
 Quote

Oliver

Anonymous
Quote by Dirk:
Quote by Oliver: I had added "Anonymous" to most groups. At least to the Story Admin and Topic Admin groups.

Ouch. Why would you want to do such a thing? If it had worked, that would have enabled any person visiting your site to edit stories.

Besides, how did you even manage to do that? Geeklog shouldn't let you do it.

bye, Dirk


It happened when I added all users to Story Admins and Topic Admin with edit group. The list on the left had "Anonymous" as the first username, which got picked with the rest of the users. When everyone was added, the list on the right didn't list Anonymous anymore. But the database shows that anonymous was still added.

It's not a public site, so there wasn't really any security issues. And having anonymous as a Story admin would actually be ok. Except that is does not work Smile

So I suppose the bug is either:
a) Anonymous user should not show up in the group edit lists
or
b) Using anonymous in various admin groups does not work
 Quote

All times are EDT. The time is now 12:21 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content