Welcome to Geeklog Friday, January 17 2020 @ 11:10 am EST

News

Geeklog 2.0.0 BETA 2

  • Friday, July 13 2012 @ 10:49 am EDT
  • Contributed by:
  • Views: 5,535
Announcements

The second beta version of Geeklog 2.0.0 is now available for download.

See this article about Beta 1 for the full list of new features found in Geeklog 2.0.0. Plugin and theme developers should read this post as well since it includes valuable information on what has changed with plugins and themes that could make their current releases incompatible with Geeklog 2.0.0

For the full list of bug fixes found in Geeklog 2.0.0 Beta 2 please read the included change log found in the docs directory of the download.

Geeklog 2.0.0 BETA 1

  • Thursday, May 24 2012 @ 10:30 am EDT
  • Contributed by:
  • Views: 9,681
Announcements

The first beta version of Geeklog 2.0.0 is now available for download.

New features in this version include:

  • Improved strength of password hashing
  • Allow Topics to have child Topics
  • Allow Articles, Blocks and other Plugin objects to be associated with more than one Topic
  • Topic Breadcrumb support
  • Emergency Rescue Tool is included with the Geeklog Install
  • Added support for MySQLi
  • Add Stop Forum Spam and Spam Number of Links Modules to Spam-X
  • A new theme called Denim which is based on Responsive Web Design
  • A new theme called Modern Curve
  • Comments Form on same page as article

... as well as a lot of other improvements. The complete list can be found in the history.txt file located in the download.

The implementation of the new Topic features required changing how Topics are handled in Geeklog. For this reason there are a few Geeklog plugins that are not compatible with this new Geeklog version. Most of the plugins that are incompatible are ones that install their own blocks and/or create a centerblock. Upgrading a Geeklog site to 2.0.0 with plugins that are currently installed that do deal with blocks or topics could cause your site not to function. These plugins should be disabled before upgrading Geeklog. The current release of the Forum plugin (2.8.0) is not yet compatible with Geeklog 2.0.0 but by the time of the final release (or soon after) a new version of the Forum plugin will be released which will be fully compatible.

We would also like to put a request out there for translators. If you speak and write another language besides English or Japanese and would like to contribute to Geeklog please join the geeklog-translations mailing list. Translating Geeklog isn't complicated. Instructions can be found on the Geeklog Wiki or simply ask on the translation list.

We would like to encourage you to download this beta version, try it out, and give us your feedback. This is a beta version and it may still contain bugs. If you find any please report them in our Bug Tracker. We also do not recommend running beta versions on "live" sites. We do plan on rolling out updates over the next weeks with the final version hopefully ready to ship in late June.

For more details on the changes plugin developers will need to make moving forward please read below...

We're back ...

  • Thursday, May 24 2012 @ 04:49 am EDT
  • Contributed by:
  • Views: 4,083
Geeklog.net

In case you were encountering an error message when calling up geeklog.net earlier today: We had a scheduled update of the server software that had some unscheduled ;-) side effects. Everything should be working as expected again now - and if not, please let us know.

Page navigation