Welcome to Geeklog Saturday, September 26 2020 @ 01:16 pm EDT

Geeklog Forums

Another plugin issue-Jquery


smgizmos

Anonymous
I have installed jquery successfully. Added the <div id="contact"></div> code to my header.thtml file but the form does not appear. Not sure if there is any other file I need to update.

(function() {
var ga = document.createElement('script'Wink; ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www'Wink + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script'Wink[0]; s.parentNode.insertBefore(ga, s);
})();

</script>

</head>

<body dir="{direction}">
<div id="contact"></div>
<div class="bodyinner">
<div class="header-logobg-container-outer">
<table width="100%" border="0" cellpadding="0" cellspacing="0" class="header-logobg-container-inner">
<tr>
<td class="header-logobg-left">
<a href="{site_url}/">{site_slogan}</a>
</td>
<td class="header-logobg-right">
<img src="{layout_url}/images/logo-right.png">


Also the Jquery section, I see this. I do not see any other settings which I am assuming should be there maybe I am wrong.

jQuery

Welcome to the jQuery plugin, smgizmos!

Install, upgrade and usage documentation is online.

The jQuery plugin configuration is now also online.

Please help with this. Thanks.
 Quote

Status: offline

Roccivic

Forum User
Moderator
Registered: 19/05/10
Posts: 136
Go to the geeklog configuration page, then in the "Configuration Sections" menu on the left select "jQuery". In the "Plugins" tab set "Use Feedback plugin" to "yes". Hope this helps.

Rouslan

 Quote

smgizmos

Anonymous
Hi Chatty,

Thanks, have enabled it, check screenshot here http://smartphonegizmos.com/images/temp/jquerynotworking.jpg , still not working Frown

Incidentally even ckeditor which I had enabled is not working so perhaps something wrong with my jquery implementation itself?

Apart from adding <div id="contact"></div> code to header.thtml file is there any other modification I need to do in any file or configuration? Thanks.
 Quote

Status: offline

Roccivic

Forum User
Moderator
Registered: 19/05/10
Posts: 136
Quote by: smgizmos

Hi Chatty,


who? lol

Quote by: smgizmos

Incidentally even ckeditor which I had enabled is not working so perhaps something wrong with my jquery implementation itself?


To turn on ckeditor you must make sure that fckeditor is disabled first. If you run firefox, do you get any errors in the "error console"? Also what geeklog version do you have? i had problems with the jQuery plugin in 1.8.0hg. I think that was because this new version contains jQuery already...

Rouslan
 Quote

smgizmos

Anonymous
Sorry, I meant Roccivic Smile

I have geeklog version 1.7.1. The advanced editor and the wikitexteditor is set to False in the configuration section.
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
smgizmos, you certainly get a path issue. There is a lot of error 404 Not found on your pages :
GET jquery.contactable.php
http://smartphonegizmos.com//jquery/feedback/jquery.contactable.php
404 Not Found

GET contactable.css
http://smartphonegizmos.com//jquery/feedback/contactable.css
404 Not Found

GET ckeditor.js
http://smartphonegizmos.com//jquery/ckeditor/ckeditor.js
404 Not Found

GET jquery.js
http://smartphonegizmos.com//jquery/ckeditor/adapters/jquery.js
404 Not Found


::Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

smgizmos

Anonymous
Thanks, I just noticed th feedback folder was in the wrong directory. It works now. am working on the path issue. Thanks for all the help.
 Quote

All times are EDT. The time is now 01:16 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content