Welcome to Geeklog, Anonymous Wednesday, October 05 2022 @ 08:18 pm EDT

Geeklog Forums

Errors


Lizard

Anonymous
Hi there,

Me again. lol.

I was just curious to find out why I am having difficulties when a new user signs up through my Geeklog site and is not able to access their albums through the Gallery2 programme?
We normally get the following errors:

Error (ERROR_MISSING_OBJECT, ERROR_UNKNOWN) : Missing object for 9804

* in modules/core/classes/GalleryStorage/GalleryStorageExtras.class at line 2054 (gallerycoreapi::error)
* in modules/core/classes/GalleryStorage/GalleryStorageExtras.class at line 98 (gallerystorageextras::_identifyentities)
* in modules/core/classes/GalleryStorage.class at line 314 (gallerystorageextras::loadentities)
* in modules/core/classes/helpers/GalleryEntityHelper_simple.class at line 71 (mysqlstorage::loadentities)
* in modules/core/classes/GalleryCoreApi.class at line 2361 (galleryentityhelper_simple::loadentitiesbyid)
* in modules/core/classes/GalleryTheme.class at line 1291 (gallerycoreapi::loadentitiesbyid)
* in themes/matrix/theme.inc at line 65 (matrixtheme::loadcommontemplatedata)
* in modules/core/classes/GalleryTheme.class at line 932 (matrixtheme::showalbumpage)
* in modules/core/classes/GalleryView.class at line 301 (matrixtheme::loadtemplate)
* in main.php at line 465 (showitemview::doloadtemplate)
* in main.php at line 104
* in main.php at line 88

Lizard.
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
So you're using the User Albums module in G2?
In Gallery Admin -> User Albums set "Create albums" to "When first accessed"

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Lizard

Anonymous
Hi,

Sorry. I just read back my first message and I realised I did not explain this problem clearly. My appologies.
I have set up an album for new users which is accessible through the Gallery2 programme, but the Admin is not able to access the new user album and that's when the error is shown on the screen. The new user can access their own album with no problems at all.
I am using the User Albums module in G2 which is set to create albums when user is created and that is working fine.

Lizard.
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
I still don't understand.
You as Admin cannot visit the album that contains the user albums?
Or you as Admin cannot visit the individual user albums?

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Lizard

Anonymous
Hi,

Me as admin can not visit the album which contains the user albums. It is shown on the screen, but when I click on it the error comes up.
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
I've helped one other w/ this same issue once.
A user was 1/2 created before they clicked away or closed their browser.
Its best to have the user albums created on first visit to gallery like I said above
Some passers-by login but never visit your gallery or expect their own album - so you won't have a ton of extra empty albums hanging around.

But to fix your problem, I'd likely have to edit your database.

-s

FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Lizard

Anonymous
Hi,

Thank you for your replies. I am currently fighting off hackers from China, but I will continue with my project shortly.
Be aware that there are a lot of them trying to gain access to websites and personal information. It has been going on for a while, but even more so recently.

Lizard.
 Quote

All times are EDT. The time is now 08:18 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content