Welcome to Geeklog, Anonymous Monday, April 22 2024 @ 03:00 am EDT

Geeklog Forums

Language and G2Bridge


Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
No matter what Im changing, I cant get gallery to use the right language.
This site use only one language, but gallery still only use english when logged in via GL.
Using gallery directly, right language are used...

What am I missing????
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
Am I missing your language?
Text Formatted Code

    $GL_to_G2_language = array(
        //'bosnian'=>'xx',  // *** No mapping
        'bulgarian'=>'bg',
        'chinese_big5'=>'zh',
        'chinese_gb2312'=>'zh',
        'chinese_simplified_utf-8'=>'zh_TW',
        'chinese_traditional_utf-8'=>'zh',
        //'croatian_utf-8'=>'xx',   // *** No mapping
        //'croatian'=>'xx', // *** No mapping
        'czech'=>'cs',
        'danish'=>'da',
        'dutch'=>'nl',
        'english_utf-8'=>'en_GB',
        'english'=>'en_GB',
        'finnish_utf-8'=>'fi',
        'finnish'=>'fi',
        'french_canada'=>'fr',
        'french_france'=>'fr',
        'german_formal'=>'de',
        'german_utf-8'=>'de',
        'german'=>'de',
        'hebrew'=>'he',
        'hellenic'=>'el',
        //'indonesian'=>'xx',   // *** No mapping
        'italian'=>'it',
        'japanese_utf-8'=>'ja',
        'japanese'=>'ja',
        'norwegian'=>'no',
        'polish'=>'pl',
        'portuguese_brazil'=>'pt_BR',
        'portuguese'=>'pt_PT',
        //'romanian'=>'xx', // *** No mapping
        'russian'=>'ru',
        //'slovak'=>'xx',   // *** No mapping
        'slovenian'=>'sl',
        'spanish_argentina'=>'es',
        'spanish'=>'es',
        'swedish'=>'sv',
        'turkish'=>'tr'
        );
 


This is not my strong point, so if there are any I'm missing please fill me in.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
Ah!
Added 'norwegian_utf-8'=>'no',
That did the trick Wink

Its always in the last place you look! Thanks agian!

And a little follow-up:
How to tweak for better performance?
Page-rendering gets from 0,23 sec, to 1,20 sec with G2Bridge enabled.
After setting cache options i G2, the time drops to 0,93 sec..
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
It all depends on the number of options enabled in G2.
G2 Performance_Tips

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
Thank you so much!
 Quote

All times are EDT. The time is now 03:00 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content