Welcome to Geeklog, Anonymous Tuesday, October 04 2022 @ 05:54 am EDT

Geeklog Forums

1.3.5 -->> 1.5.0 upgrade won't work


Status: offline

libexec

Forum User
Newbie
Registered: 08/01/02
Posts: 4
Hi all
I'm trying to upgrade from an ancient 1.3.5 GL (with 32k stories!) to the brand-new 1.5.0 version. Just the database and stories' images.

I'm following the usual upgrade process (I like the new install script, really!), BUT after telling the upgrade process what is the current version (I select 1.3.5, it is really 1.3.5sr1) the server replies with:

Text Formatted Code
Fatal error: Call to undefined function get_SP_ver() in /var/www/html/admin/install/index.php on line 1215


I can't find where on earth (or in the server, at least) is that get_SP_ver() function defined!

Any line will be much appreciated. Will try to upgrade to 1.4.1 for the while...

Kind regards!

Libexec
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Whoops, nice catch. That function was accidentally removed from the install script, even though it's still needed when you upgrade from an old Geeklog release.

You can grab it from the 1.4.1 install script or from CVS.

bye, Dirk
 Quote

All times are EDT. The time is now 05:54 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content