Welcome to Geeklog Thursday, May 28 2020 @ 04:26 am EDT

Geeklog Forums

No News to Display.

Page navigation


Status: offline

ehelm

Forum User
Chatty
Registered: 09/04/03
Posts: 37
Hi,
Could someone explain to me what is happing. When going into my site from some places I get "No News to Display". Others places have no problem. I have not configured anything in the Spam-X plugin, all is default.

- Confused:
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
"No News to display" means that there are no stories under that topic that the current user is allowed to see. It doesn't have anything to do with Spam-X.

If that doesn't help, give as a URL ...

bye, Dirk
 Quote

Status: offline

ehelm

Forum User
Chatty
Registered: 09/04/03
Posts: 37
ok My URL is http://www.helm.no
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Well, the "Topics" block is empty for me (apart from the Home link). So you either have no topics or the topics are not accessible for anonymous users like myself.

Which is pretty much what the "No news to display" message is trying to tell you.

bye, Dirk
 Quote

Status: offline

ehelm

Forum User
Chatty
Registered: 09/04/03
Posts: 37
The Anonymous access is ticked on. But the strange thing is from most places it works fine( seeing all topics and storys) And also from many other places (places meaning physical locations) is looks like you explained ""Topics" block is empty "

This happend after the upgrade to 1.5.0

 Quote

Status: offline

ehelm

Forum User
Chatty
Registered: 09/04/03
Posts: 37
Anyone????? :pray:
 Quote

Status: offline

Jokke_K

Forum User
Newbie
Registered: 24/02/04
Posts: 9
We had same kind of problems with our system, when using finnish -language file. I'm still investigating the problem, but it might be caused by configuration editor.

One of our user had problems with "äöå" after 1.5.0 upgrade and I noticed that his language setting was "finnish" in database instead of "finnish_utf-8" ( I don't know why, all other users had finnish_utf-8 and User settings was Finnish to all).

I was fixing this and changed global language to English and then back to Finnish (in admin tools) and get exactly same error.

I changed language_files in gl_conf_values back to

a:2:{s:2:"en";s:13:"english_utf-8";s:2:"de";s:19:"german_formal_utf-8";}

in database and now system is working.
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1297
Quote by: ehelm

The Anonymous access is ticked on.

For the topic AND also each story? Stories are not with a future date? You would see them as admin (ID=2). Have you tried it with a test user who is non admin?
 Quote

Status: offline

ehelm

Forum User
Chatty
Registered: 09/04/03
Posts: 37
Heyy Jokke_k

Thanks ...you nailed my problem. All is running great now. :banana:

please let me know when you find the reason for this. I would like to use the norwegian_utf-8. When going back to "no" the problems begin again.
 Quote

Status: offline

Jokke_K

Forum User
Newbie
Registered: 24/02/04
Posts: 9
Try this (or use phpmyadmin)

mysql> update gl_users set language = 'finnish_utf-8'; (we have only finnish users)

(gl=whateveryouhave and finnish=norwegian)

I checked this from database backup and there was also "NULL" instead of "finnish_utf-8"
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Jokke_K

I checked this from database backup and there was also "NULL" instead of "finnish_utf-8"


NULL means that it will use the site's default language. These are users that never changed their profile.

bye, Dirk
 Quote

Status: offline

Jokke_K

Forum User
Newbie
Registered: 24/02/04
Posts: 9
Is it possible that, if Anonymous="NULL" and you add new language files in configuration editor (Languages and Locale-> language files) it causes this error?

I'm not able to test this just now.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
For Anonymous, the setting is always NULL, since you can't log in as that user.

I can't really think of any problems you could cause by adding or removing languages, as long as the default language is set and the corresponding language file exists.

bye, Dirk
 Quote

Status: offline

ehelm

Forum User
Chatty
Registered: 09/04/03
Posts: 37
What I'm seeing now when changing to norwegian_utf-8 even when I give the Anonymous gl_users set language value norwegian_utf-8 is that it's still not loading correctly. When I login with my user ID it looks fine.

Any ideas?

 Quote

Status: offline

ehelm

Forum User
Chatty
Registered: 09/04/03
Posts: 37
I have now put everthing to default English and all storys on the frontpage are showing again. I tested the site from my cellphone now just to test the Anonymous access. The page is loading correct from IE but when I try Opera i get "No New to Display" and the topics are not showing.

what's going on here? Anyone? Confused

 Quote

Status: offline

kyngchaos

Forum User
Junior
Registered: 29/03/06
Posts: 23
Same problem here. I did a little debugging and it seems to be a problem of localized topic names. With the language set, the SQL query becomes:

PHP Formatted Code

SELECT COUNT(*) AS count FROM gl_stories AS s WHERE (date <= NOW()) AND (draft_flag = 0) AND (s.tid LIKE '%\_en') AND frontpage = 1  AND s.tid != 'archives'
 


It's searching for localized topic IDs (s.tid). None of my topics from pre-GL 1.5 have '_en' in their IDs. So, changing the languages and language_files conf values to null fixes the problem, but I have to do that directly in phpmyadmin. Perhaps the new configuration pages need to have a way to unset values (where appropriate), an opposite action to the "Restore" that appears when a value is unset? (maybe deleting all entries on the conf page will do this?)

I guess the problem is a distinction between a site that supports multiple languages in the site text, where languages and language_files are unset, and a site that supports multiple languages in content, where languages and language_files are set and there are multiple versions of topics, calendars, static pages,...
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
If you had a non-multi-lingual site before the upgrade to 1.5.0, then that should still be the case after the upgrade. If, however, you accidentally enable the multi-language feature, there is indeed no way currently to revert that, other than diving into the database.

Or you could try the fixed version from CVS. Download revision 1.42.2.1 of the config class from here. It will display a (x) next to options that can be reset.

bye, Dirk
 Quote

Status: offline

ehelm

Forum User
Chatty
Registered: 09/04/03
Posts: 37
Thanks for the really great explanation. I'm understanding most of it but witch values should be changed direct in the database and witch values in the Config page? When you say it should be null does that meen a empty value or 0 or text NULL?

Dirk,
I would like to use the multi-lingual funtion but am not able to get it to show stories to all Anonymous users. It is shown some not all. Like I said before. It can work from home or from a nother place but not always. At some freinds it is showing fine but others are getting "No News to Display"
 Quote

Status: offline

kyngchaos

Forum User
Junior
Registered: 29/03/06
Posts: 23
I'm understanding most of it but witch values should be changed direct in the database and witch values in the Config page?

Exactly what I mentioned: languages and language_files in the conf_values table.

When you say it should be null does that meen a empty value or 0 or text NULL?

Actually, set them both to:

unset

I found that null would give me a PHP error on the configuration page.
 Quote

Status: offline

ehelm

Forum User
Chatty
Registered: 09/04/03
Posts: 37
The only thing with languages in my conf_values table is: path_language and rdf_language

Dirk,
How do you see if the multi-languages funtion is turned on?
 Quote

Page navigation

All times are EDT. The time is now 04:26 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content