Subject: No News to Display.

Posted on: 17/07/08 02:58am
By: ehelm

Hi,
Could someone explain to me what is happing. When going into my site from some places I get "No News to Display". Others places have no problem. I have not configured anything in the Spam-X plugin, all is default.

- Confused:

Re: No News to Display.

Posted on: 17/07/08 03:45am
By: Dirk

"No News to display" means that there are no stories under that topic that the current user is allowed to see. It doesn't have anything to do with Spam-X.

If that doesn't help, give as a URL ...

bye, Dirk

Re: No News to Display.

Posted on: 17/07/08 05:08am
By: ehelm

ok My URL is http://www.helm.no

Re: No News to Display.

Posted on: 17/07/08 05:19am
By: Dirk

Well, the "Topics" block is empty for me (apart from the Home link). So you either have no topics or the topics are not accessible for anonymous users like myself.

Which is pretty much what the "No news to display" message is trying to tell you.

bye, Dirk

Re: No News to Display.

Posted on: 17/07/08 05:31am
By: ehelm

The Anonymous access is ticked on. But the strange thing is from most places it works fine( seeing all topics and storys) And also from many other places (places meaning physical locations) is looks like you explained ""Topics" block is empty "

This happend after the upgrade to 1.5.0


Re: No News to Display.

Posted on: 17/07/08 08:27am
By: ehelm

Anyone????? :pray:

Re: No News to Display.

Posted on: 17/07/08 10:16am
By: Jokke_K

We had same kind of problems with our system, when using finnish -language file. I'm still investigating the problem, but it might be caused by configuration editor.

One of our user had problems with "äöå" after 1.5.0 upgrade and I noticed that his language setting was "finnish" in database instead of "finnish_utf-8" ( I don't know why, all other users had finnish_utf-8 and User settings was Finnish to all).

I was fixing this and changed global language to English and then back to Finnish (in admin tools) and get exactly same error.

I changed language_files in gl_conf_values back to

a:2:{s:2:"en";s:13:"english_utf-8";s:2:"de";s:19:"german_formal_utf-8";}

in database and now system is working.

Re: No News to Display.

Posted on: 17/07/08 11:31am
By: 1000ideen

Quote by: ehelm

The Anonymous access is ticked on.

For the topic AND also each story? Stories are not with a future date? You would see them as admin (ID=2). Have you tried it with a test user who is non admin?

Re: No News to Display.

Posted on: 17/07/08 12:53pm
By: ehelm

Heyy Jokke_k

Thanks ...you nailed my problem. All is running great now. :banana:

please let me know when you find the reason for this. I would like to use the norwegian_utf-8. When going back to "no" the problems begin again.

Re: No News to Display.

Posted on: 17/07/08 01:46pm
By: Jokke_K

Try this (or use phpmyadmin)

mysql> update gl_users set language = 'finnish_utf-8'; (we have only finnish users)

(gl=whateveryouhave and finnish=norwegian)

I checked this from database backup and there was also "NULL" instead of "finnish_utf-8"

Re: No News to Display.

Posted on: 17/07/08 01:55pm
By: Dirk

Quote by: Jokke_K

I checked this from database backup and there was also "NULL" instead of "finnish_utf-8"


NULL means that it will use the site's default language. These are users that never changed their profile.

bye, Dirk

Re: No News to Display.

Posted on: 17/07/08 02:02pm
By: Jokke_K

Is it possible that, if Anonymous="NULL" and you add new language files in configuration editor (Languages and Locale-> language files) it causes this error?

I'm not able to test this just now.

Re: No News to Display.

Posted on: 17/07/08 02:49pm
By: Dirk

For Anonymous, the setting is always NULL, since you can't log in as that user.

I can't really think of any problems you could cause by adding or removing languages, as long as the default language is set and the corresponding language file exists.

bye, Dirk

Re: No News to Display.

Posted on: 17/07/08 02:58pm
By: ehelm

What I'm seeing now when changing to norwegian_utf-8 even when I give the Anonymous gl_users set language value norwegian_utf-8 is that it's still not loading correctly. When I login with my user ID it looks fine.

Any ideas?


Re: No News to Display.

Posted on: 17/07/08 05:05pm
By: ehelm

I have now put everthing to default English and all storys on the frontpage are showing again. I tested the site from my cellphone now just to test the Anonymous access. The page is loading correct from IE but when I try Opera i get "No New to Display" and the topics are not showing.

what's going on here? Anyone? Confused


Re: No News to Display.

Posted on: 17/07/08 05:14pm
By: kyngchaos

Same problem here. I did a little debugging and it seems to be a problem of localized topic names. With the language set, the SQL query becomes:

PHP Formatted Code

SELECT COUNT(*) AS count FROM gl_stories AS s WHERE (date <= NOW()) AND (draft_flag = 0) AND (s.tid LIKE '%\_en') AND frontpage = 1  AND s.tid != 'archives'
 


It's searching for localized topic IDs (s.tid). None of my topics from pre-GL 1.5 have '_en' in their IDs. So, changing the languages and language_files conf values to null fixes the problem, but I have to do that directly in phpmyadmin. Perhaps the new configuration pages need to have a way to unset values (where appropriate), an opposite action to the "Restore" that appears when a value is unset? (maybe deleting all entries on the conf page will do this?)

I guess the problem is a distinction between a site that supports multiple languages in the site text, where languages and language_files are unset, and a site that supports multiple languages in content, where languages and language_files are set and there are multiple versions of topics, calendars, static pages,...

Re: No News to Display.

Posted on: 17/07/08 05:32pm
By: Dirk

If you had a non-multi-lingual site before the upgrade to 1.5.0, then that should still be the case after the upgrade. If, however, you accidentally enable the multi-language feature, there is indeed no way currently to revert that, other than diving into the database.

Or you could try the fixed version from CVS. Download revision 1.42.2.1 of the config class from here. It will display a (x) next to options that can be reset.

bye, Dirk

Re: No News to Display.

Posted on: 17/07/08 05:36pm
By: ehelm

Thanks for the really great explanation. I'm understanding most of it but witch values should be changed direct in the database and witch values in the Config page? When you say it should be null does that meen a empty value or 0 or text NULL?

Dirk,
I would like to use the multi-lingual funtion but am not able to get it to show stories to all Anonymous users. It is shown some not all. Like I said before. It can work from home or from a nother place but not always. At some freinds it is showing fine but others are getting "No News to Display"

Re: No News to Display.

Posted on: 17/07/08 05:52pm
By: kyngchaos

I'm understanding most of it but witch values should be changed direct in the database and witch values in the Config page?

Exactly what I mentioned: languages and language_files in the conf_values table.

When you say it should be null does that meen a empty value or 0 or text NULL?

Actually, set them both to:

unset

I found that null would give me a PHP error on the configuration page.

Re: No News to Display.

Posted on: 17/07/08 06:12pm
By: ehelm

The only thing with languages in my conf_values table is: path_language and rdf_language

Dirk,
How do you see if the multi-languages funtion is turned on?

Re: No News to Display.

Posted on: 18/07/08 01:50am
By: Dirk

Configuration > Geeklog > Languages and Locale > Language

The entries "Language Files" and "Languages" should both have the "Restore" option visible for a site that does NOT use the multi-language support. If they are BOTH enabled, you do have multi-language support enabled.

bye, Dirk

Re: No News to Display.

Posted on: 20/07/08 05:49pm
By: ehelm

looking at the error log I'm seeing this one:

20.07.2008 23:41:42 - Language "english" not found in $_CONF['language_files'] array!

When I'm logged in with my user this does not happen, only with anonymous users

What does that mean? :banghead:

Re: No News to Display.

Posted on: 21/07/08 08:51am
By: ehelm

ok...now I'm really ticked off at geeklog now....

I've installed a new test site with a new installation of Geeklog 1.5.0 url: http://test-helm.helm.no

When I actived the multi-Language function. I'm getting the same problems. The Welcome to Geeklog! story is not visable to anonymous users. I've been using geeklog since 2002 and never had problems like this. Is this a bug in the system?




Re: No News to Display.

Posted on: 21/07/08 09:00am
By: Dirk

Quote by: ehelm

When I actived the multi-Language function. I'm getting the same problems. The Welcome to Geeklog! story is not visable to anonymous users.


It works as designed then ...

When you enable multi-language support, all your stories and topics must have a suffix for the language. The default "welcome" post (and the default topics) don't have that, so they won't show up. This how it worked since the feature was introduced in 1.4.1.

You should be able to view the story if you call it up directly, though. Non-multi-language aware stories and topics just won't be listed automatically.

bye, Dirk

P.S. And it does: http://test-helm.helm.no/article.php?story=welcome

Re: No News to Display.

Posted on: 21/07/08 09:10am
By: ehelm

where can I add this language suffix for the topics and Stories?

Re: No News to Display.

Posted on: 21/07/08 09:17am
By: Dirk

:rtfm: Multi-Language Support

Re: No News to Display.

Posted on: 21/07/08 09:50am
By: ehelm

I don't see where it mentions what to do with the Stories or topics???? or am I missing somthing???

Re: No News to Display.

Posted on: 21/07/08 10:24am
By: ehelm

I think I got it now,

Thanks Dirk

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=83814