Welcome to Geeklog Wednesday, May 25 2022 @ 06:23 pm EDT

Geeklog Forums

HELP!!! Install fine, but error when opening page


animalhelp

Anonymous
freakingout
Oh, my, yes I am freaking out!!! I am desperate! Can anyone help me??? My install went fine. I am on a Win server. BUT...when I go to the site where geeklog should be running I am getting the following error Parse error: parse error, unexpected T_STRING in D:\web\vhosts\animalhelp.com\httpdocs\disaster\public_html\lib-common.php on line 3974 I don't know what to do. I dont want to change things I shouldn't. And heck, there was already something else before this that I messed with. I am desperate. I am willing to give someone who can fix this payment and access, just please help! I am supposed to be running a non-profit, May Challenge - Hurricane Preparedness for Pets which starts tomorrow and I really wanted to use geeklog but have been working on this all day and can't get it running! I have geeklog on another site and have no problem with it whatsoever. I think it is so much better then Joomla, and I need a ready made, customizable, and interactive site for this project. But, all day, I can't make it work and I am freaking out!!! I will be up all night trying to get it going (if the vodka bottle doesn't tempt me too much with all this stress) so please respond ASAP http://disaster.animalhelp.com
 Quote

animalhelp

Anonymous
I forgot to mention I edited both lib_common and config using windows notepad but did upload to my site with dreamweaver. Could that be the problem?
 Quote

ironmax

Anonymous
Take a look at your paths. Windows doesn't like having periods in the path statements. Also check your config.php file to make sure you have the all names within the quotes. Just my 2 cents worth and a starting place to check. Below is a typical setup for a windows system, compare it and make your adjustments as needed. This setup works with the path layout thats within the tarball. Also check the IIS to make sure you have the root set to public_html or you will have to make adjustments within the config for that. And don't forget to verify your one path statement line pointing to your config within lib-common.php This is exactly the way I have my setup, except for some path and name changes. And it works great. One last thing, notepad like to put whitespaces in the file. Use another editor like PFE from http://www.winsite.com/bin/Info?500000017700



PHP Formatted Code

// +---------------------------------------------------------------------------+
// | (1) Database Settings                                                     |
// +---------------------------------------------------------------------------+

$_DB_host         = 'localhost';   // host name or IP address of your DB server
$_DB_name         = 'geeklog';     // name of your database,
                                   // must exist before running the installer!
$_DB_user         = 'geeklog';    // MySQL user name
$_DB_pass         = 'password';    // MySQL password

// The table prefix is prepended to each table used by Geeklog to avoid name
// collisions with other tables that may already exist in your database.
$_DB_table_prefix = 'gl_';         // e.g. 'gl_'


// +---------------------------------------------------------------------------+
// | (2) Paths                                                                 |
// +---------------------------------------------------------------------------+

// Note for Windows users: It's safe to use the forward slash '/' instead of
// the backslash '\' in paths. Make sure each path starts with a drive letter!

// This should point to the directory where your config.php file resides.
$_CONF['path']            = 'E:/WebSites/your_geeklog/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html']      = '/path/to/your/public_html/';
$_CONF['path_html']         = $_CONF['path'] . 'public_html/';


// +---------------------------------------------------------------------------+
// | (3) Site Settings                                                         |
// +---------------------------------------------------------------------------+

// Make sure this is the correct URL to your site, i.e. to where Geeklog's
// index.php file resides (no trailing slash).
$_CONF['site_url']          = 'http://www.geeklog.net';

// Some hosting services have a preconfigured admin directory. In that case,
// you need to rename Geeklog's admin directory to something like "myadmin"
// and change the following URL as well. Leave as is until you experience any
// problems accessing Geeklog's admin menu.
$_CONF['site_admin_url']    = $_CONF['site_url'] . '/admin';

// This is the return address for all email sent by Geeklog and contact info
// displayed in syndication feeds:
$_CONF['site_mail']         = 'geeklog@geeklog.net';

// Name and slogan of your site
$_CONF['site_name']         = 'Geeklog';
$_CONF['site_slogan']       = 'The Ultimate Weblog System';

 


Michael
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: animalhelp

Parse error: parse error, unexpected T_STRING in D:webvhostsanimalhelp.comhttpdocsdisasterpublic_htmllib-common.php on line 3974


:rtfm: http://www.geeklog.net/docs/install.html#corrupted
 Quote

Status: offline

animalhelp

Forum User
Newbie
Registered: 30/04/07
Posts: 2
Thanks Dirk, that helped! I downloaded Metapad and edited fresh copies of lib_commom and config. And that error is gone, but then I had another one! :banghead: "Unfortunately, an error has occurred rendering this page. Please try again later." I did go through the forums and found a couple posts with the same error, and I followed the info you gave them. How I finally fixed it: I changed this $_CONF['rootdebug'] = true; to show the errors detail here is the detail I get: An error has occurred: 2 - main(/httpdocs/disaster/system/classes/timer.class.php) [function.main]: failed to open stream: No such file or directory @ D:\web\vhosts\animalhelp.com\httpdocs\disaster\public_html\lib-common.php line 182 I did have that file where it was supposed to be, so I knew I still didn't have my paths correct. i should have had my path as D:/web/vhosts/animalhelp.com/httpdocs/disaster instead of '/httpdocs/disaster/' in BOTH lib_common.php (the path to call once config.php) and in config.php Ahhh... :pray: thank you Dirk and everyone else who gave assistance to me and others in the forums so I could finally figure it out!!! Now, just have to hurry to get my geeklog site customized and the content in quickly so it is live sometime today atleast!!! A little behind schedule, but at least its there now!!! :banana: http://disaster.animalhelp.com http://www.animalhelp.com
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: animalhelp

An error has occurred:
2 - main(/httpdocs/disaster/system/classes/timer.class.php) [function.main]: failed to open stream: No such file or directory @ D:webvhostsanimalhelp.comhttpdocsdisasterpublic_htmllib-common.php line 182


You need to use complete (absolute) paths. You only have

$_CONF['path'] = '/httpdocs/disaster/';

but it should really be

$_CONF['path'] = 'd:/web/vhosts/animalhelp.com/httpdocs/disaster/';

(and possibly similar changes in other places).

bye, Dirk
 Quote

Status: offline

animalhelp

Forum User
Newbie
Registered: 30/04/07
Posts: 2
Thanks Dirk!!! I edited my post above to show how I fixed it. You are a Geeklog God!!! :pray:
 Quote

All times are EDT. The time is now 06:23 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content