Welcome to Geeklog, Anonymous Saturday, July 13 2024 @ 06:38 pm EDT

Geeklog Forums

FileMgmt 1.5.2


Status: Banned

gtgillis

Forum User
Full Member
Registered: 11/05/03
Posts: 121
I installed the FileMgmt plugin version 1.5.2 and have noticed some unexpected behavior. What I wanted to do was set it up so only logged-in users could download file. I set "Restrict access to group 'Logged-In Users' only:" to yes but found only admins could access the files. I tried setting it to no and modifying the category access to logged-in users but still only the admins have access.

After some digging around I inserted a new record into gl_access using the feature code of filemgmt.user and the logged-in user group (13) and now it works like I want it.

How is the category access supposed to work? Does it add a record to gl_access with the selected group id and the filemgmt.user feature code?
 Quote

Jason

Anonymous
I just installed this plugin tonight and am having the same issue. I found when I set "Restrict access to group 'Logged-In Users' only:" to Yes a regular registered user who is a member of 'Logged-In Users' was able to see the files. When it was set to No, the same user wasn't able to see the files. I would have thought setting this to No would mean any registered user could see the d/l section, whether they were a member of 'Logged-In Users' or not, but it seems to be preventing members of that group from seeing the files.

I played around a bit and noticed that when I set "Restrict access to group 'Logged-In Users' only:" to No and "Enable Anonymous access:" to Yes, the user was then able to see the files. Setting "Enable Anonymous access:" back to No prevented the files from being seen again. When both of these were set to Yes the files were visible to the user.

Also, I'm having another issue which may or may not be related. When I set "Allow Logged-In uploads:" to Yes, the "Upload a file" link appears in the User block as expected. However, when I try to use it to upload a file, after entering the info and hitting the submit button I get the following error message:

File Management Plugin Error Code: 9999
ERROR: OOPS! God Knows

This happens no matter what user I am, a regular user or Admin. As Admin I am able to upload files through the "Filemgmt Admin, Add File" function so I don't think there are any write access issues on the file directories with my server. Any thoughts on what this problem might be?

thanks





 Quote

Jason

Anonymous
Sorry, I feel a bit stupid - I forgot to check the error logs and noticed there is some config rule denying the upload. I had tried to upload an .exe file (it's late, I wasn't really thinking) and the error log contained:

"Wed 29 Nov 2006 22:56:44 MST - AddNewFile - New Upload file is rejected by config rule:EzThmb_Setup.exe"

I don't suppose it would be sensible to allow even registered users (even though my site is not open to the public) to upload executables, which would explain why I didn't see that option in the Admin settings.
 Quote

All times are EDT. The time is now 06:38 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content