Welcome to Geeklog Sunday, March 29 2020 @ 08:44 am EDT

Geeklog Forums

New User Pages Plugin / Hack of Static pages some help required...


Status: offline

trampoline

Forum User
Full Member
Registered: 24/02/06
Posts: 392
I've tried to hack the Static pages plugin so I can for the basis of a new User Pages Plugin.
I have I think changed all the code for paths and SQL etc. but I get this error on installation.

PHP Formatted Code

Tue 24 Oct 22:08:09 2006 - Attempting to install the User Page plugin
Tue 24 Oct 22:08:09 2006 - Attempting to create User Page Admin group
Tue 24 Oct 22:08:09 2006 - 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '(
  uhp_id varchar(40) NOT NULL default '
',
  uhp_uid mediumint(<img src="http://www.geeklog.net/images/smiles/icon_cool.gif" ALT="Cool" TITLE="Cool" BORDER="0"> NOT NULL defa'
at line 1. SQL in question:
CREATE TABLE  (
  uhp_id varchar(40) NOT NULL default '',
  uhp_uid mediumint(<img src="http://www.geeklog.net/images/smiles/icon_cool.gif" ALT="Cool" TITLE="Cool" BORDER="0"> NOT NULL default '1',
  uhp_title varchar(12<img src="http://www.geeklog.net/images/smiles/icon_cool.gif" ALT="Cool" TITLE="Cool" BORDER="0"> NOT NULL default '',
  uhp_content text NOT NULL,
  uhp_hits mediumint(<img src="http://www.geeklog.net/images/smiles/icon_cool.gif" ALT="Cool" TITLE="Cool" BORDER="0"> unsigned NOT NULL default '0',
  uhp_date datetime NOT NULL default '0000-00-00 00:00:00',
  uhp_format varchar(20) NOT NULL default '',
  uhp_onmenu tinyint(1) unsigned NOT NULL default '0',
  uhp_label varchar(64) default NULL,
  owner_id mediumint(<img src="http://www.geeklog.net/images/smiles/icon_cool.gif" ALT="Cool" TITLE="Cool" BORDER="0"> unsigned NOT NULL default '1',
  group_id mediumint(<img src="http://www.geeklog.net/images/smiles/icon_cool.gif" ALT="Cool" TITLE="Cool" BORDER="0"> unsigned NOT NULL default '1',
  perm_owner tinyint(1) unsigned NOT NULL default '3',
  perm_group tinyint(1) unsigned NOT NULL default '2',
  perm_members tinyint(1) unsigned NOT NULL default '2',
  perm_anon tinyint(1) unsigned NOT NULL default '2',
  uhp_centerblock tinyint(1) unsigned NOT NULL default '0',
  uhp_tid varchar(20) NOT NULL default 'none',
  uhp_where tinyint(1) unsigned NOT NULL default '1',
  uhp_php tinyint(1) unsigned NOT NULL default '0',
  uhp_nf tinyint(1) unsigned default '0',
  uhp_inblock tinyint(1) unsigned default '1',
  PRIMARY KEY  (uhp_id),
  KEY user_homepage_uhp_uid (uhp_uid),
  KEY user_homepage_uhp_date (uhp_date),
  KEY user_homepage_uhp_onmenu (uhp_onmenu),
  KEY user_homepage_uhp_centerblock (uhp_centerblock),
  KEY user_homepage_uhp_tid (uhp_tid),
  KEY user_homepage_uhp_where (uhp_where)
) TYPE=MyISAM
 


Any help appreciated, I probably have made a massive but obvious error somewhere.
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 22/03/04
Posts: 1512
You neglected to specify the table name after "create table"
 Quote

All times are EDT. The time is now 08:44 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content