Welcome to Geeklog, Anonymous Tuesday, October 04 2022 @ 06:51 am EDT

Geeklog Forums

FCKeditor Toolbar Has Gone-a-Missin'


Status: offline

Wyoming

Forum User
Junior
Registered: 09/29/06
Posts: 27
This reminds me of the sheep I lost a few weeks ago: I knew there had to be a hole in the fence somewhere but finding it was the problem.....

I have the advanced editor enabled and all was hunky-dory with it until last evening - it was making life sooooo much easier for me.

Then suddenly, having made no changes (just editing stories and the like) the editor toolbar(s) have gone AWOL. I get the (+) and (-), there's an insertion bar, but there's no text box visible and no toolbar. I searched this fourm and found some suggestions but none have solved my problem.

First of all, I use the soapbox theme. Some posts have suggested that I should be using professional. So I switched to that but no joy. Professional looks exacly the same.

Watching the status bar as the story editor loads I notice that the progress listed stalls at "looking up fckeditor" and that's where it stays.

Here's what I have done:

- Ran a backup
- Made sure {advanced_editor} is in header.thtml of the themes.
- Reloaded the /fckeditor folder (I read in a post that fixed it for someone)
- Had more coffee
- Scratched my head

I'm using 1.4.0sr5-1 if that's useful information. The problem is the same in both Firefox and IE.

Any ideas? Thanks for your help!

(Oh, by the way, I eventually found the sheep a mile away and the break in the fence a lot closer to home, in case you were worrying Cool. My neighbor runs rodeo bulls behind me and they occasionally like to come visit having no respect for fences. )

Glenn
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Just checking: You still have JavaScript enabled in your browser?

bye, Dirk
 Quote

Status: offline

Wyoming

Forum User
Junior
Registered: 09/29/06
Posts: 27
Hi Dirk,

Yes, JS is still enabled. I literally changed nothing.

I've decided this is not that big a deal and am withdrawing the question. I'm the only one who will use this and it will be just as easy to create/edit in Nvu and simply paste the code as it will to do it within GL, I think. So I've turned off the advanced edit feature. I'm too new to this and don't trust myself not to make things worse in trying to fix it.

Feel free to delete this topic if it's just clutter at this point.

Thanks!

Glenn
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
Location:Canada
Glad you found your sheep - I was looking for them Shocked

Just wanted to check that you are logged in as an Admin or have story editor rights and using a postmode in the editor form set to Advanced Editor
Geeklog components by PortalParts -- www.portalparts.com
 Quote

Status: offline

Wyoming

Forum User
Junior
Registered: 09/29/06
Posts: 27
Hi Blaine,

Yeppers - logged in as admin but there is no option under postmode for Advanced Editor - Just "HTML Formatted" or "plain-old text"

Thanks for not making any Brokeback jokes. It's been a long year for us Wyoming sheep ranchers....... Embarassed
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
Location:Canada
I suspect you don't have the option in the main site config.php enabled then or your missing the advanced_editor template - but thats definitely there with the provided professional theme - so I suspect the config.php setting is not enabled.

Text Formatted Code

// +---------------------------------------------------------------------------+
// | Support for custom templates to support advanced Rich Text Editor         |
// | Checked in comment.php, submit.php, admin/story.php and                   |
// | staticpages/index.php. If set true and advanced template exists           |
// | Note: If enabled, the default postmode will be html                       |
// +---------------------------------------------------------------------------+
$_CONF['advanced_editor'] = 1;

 

Geeklog components by PortalParts -- www.portalparts.com
 Quote

Status: offline

Wyoming

Forum User
Junior
Registered: 09/29/06
Posts: 27
Nope - it's on.

Here's the thing: I originally had that set to "true," not "1" and it worked. Not sure where I came up with "true" but it had to be here.

Anyway, I just changed it to "1" and there was no change.

Are 1/0 and True/False interchangeable?

No matter. I've come up with a scheme that's working quite well for me.
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
Location:Canada
Setting to true or 1 would result in the same result in our case. We check if the setting is true and any value > 0 also evaluates to a true.

Are you sure you have tested with the provided professional theme - verify the following template exists
Text Formatted Code
admin/story/storyeditor_advanced.thtml


 
If the setting is true and the template exists, then the option in the postmodes for "Advanced Editor' should appear.
  • Verify that you are not getting a javascript error
  • Test with both IE and Firefox

Geeklog components by PortalParts -- www.portalparts.com
 Quote

Status: offline

Wyoming

Forum User
Junior
Registered: 09/29/06
Posts: 27
That file exists in both templates. I made no changes at all to the professional theme, so it's 100% what came with GL.

In FF it looks as though it never finishes loading. In IE I get the errors: "unknown toolbar item Full Window" twice (one for each, I suppose).

Ahdunno......
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
Location:Canada
Quote by Wyoming:In FF it looks as though it never finishes loading. In IE I get the errors: "unknown toolbar item Full Window" twice (one for each, I suppose).
Ok, thats new information and IE has to be getting the same error only is not so nice at displaying it. It appears you have changed the FCKeditor provided definition for the toolbars as I don't include the 'FullWindow' option in the default toolbar. The file fckeditor/myconfig.js defines the toolbars - have a look.
Geeklog components by PortalParts -- www.portalparts.com
 Quote

Status: offline

Dazzy

Forum User
Full Member
Registered: 07/19/03
Posts: 200
Location:N. Ireland
I get the not loading in firefox too, we done a custom installation of geeklog, all worked fine but when we migrated it into the main route directory and the fckeditor stopped working, I got it working in IE by setting the

Text Formatted Code
FCKConfig.CustomConfigurationsPath = '/home/sites/jinlun-owners.co.uk/public_html/fckeditor/' ;

 


before I done this IE would hide the text box altogether, therefore not allowing any text or editing to be done, but FF refuses to load it.
Dazzy
 Quote

All times are EDT. The time is now 06:51 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content