Welcome to Geeklog Saturday, May 21 2022 @ 08:50 am EDT

Geeklog Forums

Unfortunately, an error has occurred rendering this page. Please try again later.


Status: offline

tgc

Forum User
Regular Poster
Registered: 15/03/06
Posts: 82
I am trying to install cvs 1.4.1 and everything goes ok until the second page of the installer, then I get this message.
Unfortunately, an error has occurred rendering this page. Please try again later.
I looked for it in search but it seems to be a new problem. I dropped the tables in the database and ran the installer again but the same. I also "tried later" but still not working.

Frank
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
That's not a new problem but our new error handler Laughing

I assume you only got this when you were already on the success.php page? At that point, your database has probably been populated properly and then it ran into some other error, e.g. a parse error or a missing PEAR package.

If you call up your site's index page, you probably get the same message. In that case, find this new config.php variable:
PHP Formatted Code
// When set to true, this will display /detailed/ debug information in the event
// of a PHP error. ONLY set this to true with your non-production development
// environments!
$_CONF['rootdebug'] = false;
 

Set it to true and try again. You should get an error message then.

And remember to change it back to false after you get the site up and running.

bye, Dirk
 Quote

Status: offline

tgc

Forum User
Regular Poster
Registered: 15/03/06
Posts: 82
thanks for the reply. I checked the pear packages again and they seem to be complete. I set "true" in rootdebug but I only get the "unfortunately" thing and no more details. In the error log is only the dummy entry.
I once in a while install the cvs and play around and it always worked to install but this time...

Frank
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Okay, can you please disable the error handler then? You will then get a normal error (or the dreaded Blank page). I'm interested in what actually caused the problem for you, so that we can address this before we release this version. Thanks.

To disable the error handler, find this line in lib-common.php:
PHP Formatted Code
if( function_exists('set_error_handler') )
 
and replace the 'set_error_handler' with a function that is guaranteed not to exists, e.g. 'xxxset_error_handler'. Then try again.

bye, Dirk
 Quote

Status: offline

tgc

Forum User
Regular Poster
Registered: 15/03/06
Posts: 82
the error was a (slight) mistake in the path in lib-common.php. I apologize for neglecting to verify the correct pathes before I post in the forum...Embarassed

Frank
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
No problem. I was just interested to learn why the error handler would not work for you. I guess there's no way it could have worked in that case - good to know once we go live with it and other people may run into the same problem. So thanks for debugging it Cool

bye, Dirk
 Quote

Drew

Anonymous
This happened to me when I installed from cvs. I enabled debugging and saw that in /system/classes/syndication/parsefactory.class.php line 31 read as follows :


require_once('/HTTP/Request.php');


Which does not point to the "pear" directory. To resolve this I edited the line as follows:


require_once($_CONF['path_pear'] . '/HTTP/Request.php');




-drew
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Drew: require_once('/HTTP/Request.php');


Which does not point to the "pear" directory.

The leading slash shouldn't be there (and it isn't in 1.4.0 or the CVS version, AFAICS). Other than that, it's correct as it is. The path to PEAR will be set in lib-common.php, if necessary, or simply be left alone to be resolved with the server's default paths.

bye, Dirk
 Quote

Status: offline

J23

Forum User
Newbie
Registered: 24/07/05
Posts: 6
Location:Canada
Hi, Cool
I got the same error message and in my case the problem was that I did not change the location of "config.php" in the "lib-common.php", after changing it it's working fine without any problems .. Its a deal - shaking hands
http://www.info-polonia.com/
 Quote

All times are EDT. The time is now 08:50 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content