Welcome to Geeklog Saturday, May 21 2022 @ 07:54 am EDT

Geeklog Forums

system/classes/syndication/parserfactory.class.php on line 31 error message


Status: offline

barrywong

Forum User
Regular Poster
Registered: 12/04/02
Posts: 95
I believe there is a bug on Geeklog 1.4.0rc1 that is related to config.php when line:136 $_CONF['have_pear'] = true; (defaulted to "false").

When this option is set to "true:", the following error message occurs intermittently whne adding/editing a story.


Warning: main(HTTP/Request.php): failed to open stream: No such file or directory in path_to_gl/system/classes/syndication/parserfactory.class.php on line 31

Fatal error: main(): Failed opening required 'HTTP/Request.php' (include_path='.:/php/includes:/usr/share/pear') in path_to_gl/system/classes/syndication/parserfactory.class.php on line 31


I believe it is a bug with Geeklog 1.4.0rc1 because I have Geeklog 1.3.11sr2 (with the same setting "true") running on the same server without problem. Of course it could be due to a corrupt installation. I will try installing another copy in the next few days to see if this problem happens with the re-installation.

 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
1.4.0 now uses the PEAR HTTP_Request class to read feeds. Older versions used fopen(). So that's the difference.

Make sure you really have the HTTP_Request class installed (it's included in the 1.4.0 tarball). To confirm your PEAR settings, try sending an email from Geeklog. If that works, it should be able to find the HTTP_Request class as well.

bye, Dirk
 Quote

Status: offline

barrywong

Forum User
Regular Poster
Registered: 12/04/02
Posts: 95
Hi Dirk, Thank you for responding.
 Quote

Status: offline

Aerocream

Forum User
Newbie
Registered: 29/12/05
Posts: 10
Location:Naples, FL
To Fix the issue I just looked at the file names of the missing files and made sure they were teh right case. For example I have to rename request.php and url.php and this corrected my issue.

url.php to URL.php
request.php to Request.php
http://www.aerocream.com
 Quote

Christian

Anonymous
Hello!


I got the same error message, my "have_pear" is set to true.. so I assume that it's not properly installed (or at least with constraints!?) at free.fr! Is there a way to overcome this? I have Geeklog1.40sr2.

Most of the time (I guess when no pear is needed) it works, check it out at ultimate33.free.fr/geeklog33/admin

Thanks a million, I feel like I'm so close... but still not there!

Christian
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Geeklog relies on PEAR for certain functions. See Geeklog and PEAR

bye, Dirk
 Quote

Christian

Anonymous
Hello Dirk,


I've read everything about Geeklog and Pear, and I know that my problem is rooted here! What I want to know now is...

...is there a way to get Geeklog to work without having the proper classes installed on the webserver but with the constraint that the PHP function ini_set is disabled by the provider (something that I suppose, although PHP 4.1.3 is installed!!!)?

...or if there isn't - so I have to choose another CMS - what I certainly try to avoid! I'm very happy with your system running on my machine!


In hope to get at least a YES or NO,

have a nice day,
Christian
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
To quote from the FAQ article linked to above:
If you can't use ini_set and PEAR is not installed on your server, then you are out of luck and should consider switching hosting services.


Or, in other words: You get what you pay for ...

bye, Dirk
 Quote

Philprism

Anonymous
My whole website went splat with the same error after an upgrade to 1.5 If you look at the first part of the error it says 'HTTP/Request.php' 1. The pear directory is lower case 'http' on the default install 2. I changed the directory name from 'http' to 'HTTP' to match the path/name combination My website came back ON LINE............................................... Just added a story and is still on line! Smile
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Philprism

1. The pear directory is lower case 'http' on the default install


The PEAR directory in the Geeklog tarball is uppercase, HTTP, of course.

bye, Dirk
 Quote

radu

Anonymous
I comented out the line in read in parserfactory.class.php

// Require pear HTTP_REQUEST
//require_once('HTTP/Request.php'Wink;

is this OK???


Thanks
 Quote

All times are EDT. The time is now 07:54 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content