Welcome to Geeklog, Anonymous Wednesday, June 19 2024 @ 10:52 am EDT

Geeklog Forums

My pictures were there now they're gone ?? Help Please


Status: offline

linder60

Forum User
Newbie
Registered: 10/01/05
Posts: 10
Location:Rochester, New York
confused
Hi,

My pictures in my stories were there, now they are gone. When I go into admin to edit to see if there was a problem I get error msgs at the top of the page. The permissions on the items pointed out in the error msgs are all set at 644, I tried 755 and neither ones work. Any suggestions. Here are the error msgs.

Warning: getimagesize(/home/cocomilk/public_html/vintagetimes-blog/images/articles/20050928203254196_1.JPG): failed to open stream: Permission denied in /home/cocomilk/public_html/vintagetimes-blog/admin/story.php on line 746

Warning: getimagesize(/home/cocomilk/public_html/vintagetimes-blog/images/articles/20050928203254196_2.JPG): failed to open stream: Permission denied in /home/cocomilk/public_html/vintagetimes-blog/admin/story.php on line 746

Warning: getimagesize(/home/cocomilk/public_html/vintagetimes-blog/images/articles/20050928203254196_1.JPG): failed to open stream: Permission denied in /home/cocomilk/public_html/vintagetimes-blog/admin/story.php on line 824

Warning: getimagesize(/home/cocomilk/public_html/vintagetimes-blog/images/articles/20050928203254196_2.JPG): failed to open stream: Permission denied in /home/cocomilk/public_html/vintagetimes-blog/admin/story.php on line 824

Warning: getimagesize(/home/cocomilk/public_html/vintagetimes-blog/images/articles/20050928203254196_1.JPG): failed to open stream: Permission denied in /home/cocomilk/public_html/vintagetimes-blog/admin/story.php on line 746

Warning: getimagesize(/home/cocomilk/public_html/vintagetimes-blog/images/articles/20050928203254196_2.JPG): failed to open stream: Permission denied in /home/cocomilk/public_html/vintagetimes-blog/admin/story.php on line 746

If anyone can help, I'd appreciate thanks, its making me crazy, because they were there, now they are gone. I'm so confused. Banging your head

Thanks,
Linda
 Quote

Status: offline

linder60

Forum User
Newbie
Registered: 10/01/05
Posts: 10
Location:Rochester, New York
I found a post by Dirk to set permissions to 775 or 777 and it didnt help. In admin under edit where the error msgs appear I hit refresh to see if the images came up after changing permissions.

I'm still getting those error msgs plus now I'm getting this one too.

Warning: Cannot modify header information - headers already sent by (output started at /home/cocomilk/public_html/vintagetimes-blog/admin/story.php:824) in /home/cocomilk/public_html/vintagetimes-blog/lib-common.php(973) : eval()'d code on line 1

Some please help !! Can someone help me
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Well, have you checked the obvious, i.e. if the files are still there? The error message seems to indicate a permission problem, though. Check the permissions on both the files and the directory they're in.

For the other error, see the FAQ: Cannot modify header information - headers already sent by ...

bye, Dirk
 Quote

Status: offline

linder60

Forum User
Newbie
Registered: 10/01/05
Posts: 10
Location:Rochester, New York
Quote by Dirk: Well, have you checked the obvious, i.e. if the files are still there? The error message seems to indicate a permission problem, though. Check the permissions on both the files and the directory they're in.

For the other error, see the FAQ: Cannot modify header information - headers already sent by ...

bye, Dirk


Thanks Dirk,

I tried reloading them because they are still there, and I got these error msgs now.

Warning: move_uploaded_file(/home/cocomilk/public_html/vintagetimes-blog/images/articles/2005092815213297_1.jpg): failed to open stream: Permission denied in /home/cocomilk/public_html/vintagetimes-blog/system/classes/upload.class.php on line 516

Warning: move_uploaded_file(): Unable to move '/tmp/phpn0IbSn' to '/home/cocomilk/public_html/vintagetimes-blog/images/articles/2005092815213297_1.jpg' in /home/cocomilk/public_html/vintagetimes-blog/system/classes/upload.class.php on line 516

Warning: chmod(): Permission denied in /home/cocomilk/public_html/vintagetimes-blog/system/classes/upload.class.php on line 686

Warning: Cannot modify header information - headers already sent by (output started at /home/cocomilk/public_html/vintagetimes-blog/system/classes/upload.class.php:516) in /home/cocomilk/public_html/vintagetimes-blog/lib-common.php(973) : eval()'d code on line 1

I'm still reading and trying to figure out the white space deal too. Since it says line 516 in upload.class.php is that where I ck ?? I never ever went to that file ? I dont get it, or is it in the lib-common.php

I'm trying but I'm so lost, especially since they were there this morning, this all started when I added a box and put an XML icon on the site.

Thanks,
Linda
Thanks Linda
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Actually, the "Headers already sent ..." message is caused by the warnings you get. So once you fix those, it should go away.

As for the warnings: Looks like permission issues to me. Check the permissions of all the directories involved, specifically the "images" and "images/articles" directories.

bye, Dirk
 Quote

Status: offline

linder60

Forum User
Newbie
Registered: 10/01/05
Posts: 10
Location:Rochester, New York
Quote by Dirk: Actually, the "Headers already sent ..." message is caused by the warnings you get. So once you fix those, it should go away.

As for the warnings: Looks like permission issues to me. Check the permissions of all the directories involved, specifically the "images" and "images/articles" directories.

bye, Dirk


Hi Dirk,

Thanks for all the help, your explainations were good and understandable and made sense. I tried changing a ton of permissions. I got so totally frustrated, because I didnt change any settings, I had no need to, I couldnt figure out why this suddenly became a problem.

So I uninstalled and started over. The only problem I'm having with the new install is, when I click on DB Backup, I get this error message,

There was an error.

ERROR: Directory /home/cocomilk/public_html/vintagetimes-blog/backups/ is not accessible.


Go Figure. I havent even hardly done anything and its having a situation already.

Thanks,
Linda
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Permissions, again.

Did you run the check script (linked from the success page after the install)? http://yourgeeklogsite/admin/install/check.php

bye, Dirk
 Quote

Status: offline

linder60

Forum User
Newbie
Registered: 10/01/05
Posts: 10
Location:Rochester, New York
Quote by Dirk: Permissions, again.

Did you run the check script (linked from the success page after the install)? http://yourgeeklogsite/admin/install/check.php

bye, Dirk


Hi Again Dirk,

The link never showed up after install. so I just plugged that into my address bar and got this error msg:
Not Found
The requested URL /vintagetimes-blog/admin/install/check.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/1.3.33 Server at www.cocomilkcollectibles.com Port 80

Go Figure AGAIN !! Its getting silly. Banging your head
 Quote

Status: offline

linder60

Forum User
Newbie
Registered: 10/01/05
Posts: 10
Location:Rochester, New York
Quote by Dirk: Permissions, again.

Did you run the check script (linked from the success page after the install)? http://yourgeeklogsite/admin/install/check.php

bye, Dirk


I forgot to tell you I checked permissions on the db backup directory and its currently set at 755.

Thanks,
Linda
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
You must have deleted the install directory then, which is good practice but counterproductive in this case ... Simply upload it again.

Permission problems have been discussed here about a gazillion times. So please excuse me when I simply point you to the installation instructions (step 3) ...

bye, Dirk
 Quote

linder60

Anonymous
Quote by Dirk: You must have deleted the install directory then, which is good practice but counterproductive in this case ... Simply upload it again.

Permission problems have been discussed here about a gazillion times. So please excuse me when I simply point you to the installation instructions (step 3) ...

bye, Dirk


Hi Dirk,

I cant find the install directory, but I didnt delete or change any files there, even though I saw that you should do that once everything is done. As far as install, I read the Docs, install stuff, but it kind of was a self install through my cPanel, it was in the scripts library there, I just typed in the path and hit install and it was done and working.

If you can steer me to the install directory file so I can upload a new directory that would be great (unless of course I screw that up too).

But I just changed permissions on the db backup directory to 777 did my backup and then reset the permissions back to where it was. I hope that was okay to do, I thought that would be a quick fix anyway so at least its backed up for now.

Thanks for all the patience and help, sorry for being such a pain.

Linda
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by linder60: but it kind of was a self install through my cPanel

Ah, another of those. I guess we really have to start writing FAQ entries for people using one of those auto-installers ...

As you may have seen in the installation instructions, Geeklog needs write permissions on a few specific files and directories. The exact permissions depend on how your webserver is set up. 775 for directories and 664 for files is usually fine. 777 and 666 may be necessary on some setups.

So, in your case, if backups don't work with 755 or 775 but only with 777, then try to set the permissions on the other directories (images/articles, images/userphotos, backend, data) to 777 as well.

The check.php script simply tries to write into all those directories and then tells you if it succeeded. You can download it from CVS (use the Download link in the upper right corner, then copy it into admin/install, creating that directory first, if necessary).

bye, Dirk
 Quote

All times are EDT. The time is now 10:52 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content