Welcome to Geeklog, Anonymous Sunday, May 26 2024 @ 08:12 pm EDT

Geeklog Forums

New Here - Email Question - I cant find the file I need to change


Status: offline

linder60

Forum User
Newbie
Registered: 10/01/05
Posts: 10
Location:Rochester, New York
confused
Hi everyone,

Great forum, I've been looking for about 4 hrs and cant find the file I need.

When I signed up for an acct to test the site it went great, it sent the confirmation email with the password and a link to the blog from the email, at the very bottom of the email.

My problem is it links to the wrong place, I need to change it to http://www.cocomilkcollectibles.com/vintagetimes-blog/index.php

But I cant find the file to get this changed. All I want to do is change the link in the email.

Oops one more thing, above the date in the blog where it has welcome to vintagetimes-blog, when you click on it, you end up at the index files, any thoughts on where I might have messed that up.

Thanks for any help,
Linda

my blog
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
If I understand your problem correctly, then if the second issue would be fixed, you wouldn't need to fix the first one?

Geeklog always uses $_CONF['site_url'] when it refers to the URL of your blog. And it also uses that URL in the emails.

That URL shouldn't end in a slash, btw. Notice how you have 2 slashes in some of your URLs? Make sure you have

$_CONF['site_url'] = 'http://www.cocomilkcollectibles.com/vintagetimes-blog';

in your config.php (or without the "www.", if you prefer that).

Now, the actual issue is that your webserver isn't configured to look for index.php files when a directory is called up. Either talk to your hosting service or, if you have access to your webserver's configuration, make sure you have something like

DirectoryIndex index.php index.html

in your httpd.conf or local .htaccess file.

bye, Dirk
 Quote

Status: offline

linder60

Forum User
Newbie
Registered: 10/01/05
Posts: 10
Location:Rochester, New York
Hi Dirk,
Thanks for the quick reply, I ck'd my .htaccess file and it does have the DirectoryIndex index.html in it.

Here is part of my config.php I removed the ending slash in the site url. and it didnt help, it didnt help.

// Note for Windows users: It's safe to use the forward slash '/' instead of
// the backslash '' in paths. Make sure each path starts with a drive letter!

// This should point to the directory where your config.php file resides.
$_CONF['path'] ='/home/cocomilk/public_html/vintagetimes-blog/';

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['path_html'] ='/home/cocomilk/public_html/vintagetimes-blog/';


// +---------------------------------------------------------------------------+
// | (3) Site Settings |
// +---------------------------------------------------------------------------+

// Make sure this is the correct URL to your site, i.e. to where Geeklog's
// index.php file resides (no trailing slash).
$_CONF['site_url'] ='http://cocomilkcollectibles.com/vintagetimes-blog';

I'm not sure what to do ? !

Sorry, to be a pain.
Linda

Quote by Dirk: If I understand your problem correctly, then if the second issue would be fixed, you wouldn't need to fix the first one?

Geeklog always uses $_CONF['site_url'] when it refers to the URL of your blog. And it also uses that URL in the emails.

That URL shouldn't end in a slash, btw. Notice how you have 2 slashes in some of your URLs? Make sure you have

$_CONF['site_url'] = 'http://www.cocomilkcollectibles.com/vintagetimes-blog';

in your config.php (or without the "www.", if you prefer that).

Now, the actual issue is that your webserver isn't configured to look for index.php files when a directory is called up. Either talk to your hosting service or, if you have access to your webserver's configuration, make sure you have something like

DirectoryIndex index.php index.html

in your httpd.conf or local .htaccess file.

bye, Dirk
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by linder60: Thanks for the quick reply, I ck'd my .htaccess file and it does have the DirectoryIndex index.html in it.

Then add "index.php" if you don't have it.


Quote by linder60: I removed the ending slash in the site url. and it didnt help, it didnt help.

That was only a side note. The actual problem is the missing index.php for your DirectoryIndex directive.

bye, Dirk
 Quote

Status: offline

linder60

Forum User
Newbie
Registered: 10/01/05
Posts: 10
Location:Rochester, New York
Dirk,

I thought it would be in there considering at least half of the website I have the blog linked to is run on php, but it wasnt so I added it, now the link in the email works. Thanks So Much.
You're the best.

Linda

Quote by Dirk:
Quote by linder60: Thanks for the quick reply, I ck'd my .htaccess file and it does have the DirectoryIndex index.html in it.

Then add "index.php" if you don't have it.


Quote by linder60: I removed the ending slash in the site url. and it didnt help, it didnt help.

That was only a side note. The actual problem is the missing index.php for your DirectoryIndex directive.

bye, Dirk
 Quote

All times are EDT. The time is now 08:12 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content