Welcome to Geeklog, Anonymous Saturday, November 26 2022 @ 04:59 pm EST

Geeklog Forums

My geeklog with gallery installation experience


Status: offline

Porkchop

Forum User
Newbie
Registered: 05/16/05
Posts: 4
This process wasnt easy, and I havent seen any other posts like this, so I thought I should share. I came into this project with zero experience with geeklog or gallery, and it took me around 6 hours to get it all working properly. Keep in mind I did the entire install via ftp and myphpadmin for the database. To avoid too much confusion, I'm going to leave out most of my mistakes and just create a general list of the steps I took. This is how I installed gallery v1.4.1-pl1 on geeklog 1.3.11 and got gallery wrapped in my theme. Feel free to correct me on any errors and I will edit this and fix them.

I did a new install of geeklog 1.3.11 with a new database.
This went perfectly with the supplied directions, good job to the designers of the installation docs.

I installed the Commando_v1 theme from axonz.com.
Copied the theme folder to the /layout directory, changed config.php. Easy.

I installed gallery.
I downloaded gallery from gallery.sourceforge.net along with the netpbm binaries from the same site.
This is where things started to get a little tricky, and took most of my time. I copied the gallery files to /gallery and created a /gallery/albums directory.

I launched the gallery setup and noticed many errors on the first saying my .htaccess was not being obeyed, so I had to email my web host with the httpd.conf code for them to add it, after they did, the errors were still there, but after reading through the docs, I felt it was ok to continue, so i did. The gallery install was pretty straight forward, on page 3 I made sure to go to the bottom of the page and make sure embedded was set to Geeklog and put in the path to my lib_common.php . This took me to the final page and I entered the gallery. This page first looked a little wierd, it was completely white but I could tell that it was some what embedded into geeklog because same footer was on the bottom of the page that was on the bottom of my geeklog front page. So I created an album and tried to add a photo through the web form on the menu and noticed that the process went ok, but the thumnail or photo wasnt added. So after looking for help, i found the setup/check_netpbm.php script and I saw that I was getting a 127 error on all the files and also that my netpbm file location was not in my base_dir. So I moved my files from the /gallery/netpbm directory to the root directory of my web share (which was listed on the check page as being in my base_dir), and relaunched the check page, everything came back OK this time, so I went back in my gallery and it still looked the same, but I was able to add a photo with thumbnail ok through the web form.

Now I had to embed gallery into my geeklog theme. Every forum post made this seem so easy, I couldnt figure out why mine wasnt working correctly, I still had a plain white background. So after narrowing down the file that "did the work" so to speak, to /gallery/html_wrap/wrapper.header I started to compare the code with other samples and noticed that mine had a line that simply said COM_siteHeader(); while the others had the word echo infront of that line, so i added echo to mine and it worked! My gallery was now wrapped in my GL layout.

Now I had to add a link to geeklog to get to my gallery.
I edited my header.thml file and added a simple html link after {allowed_menu_elements} <a href="/gallery">Gallery</a>.

Now I go back to my geeklog and I have a link to the gallery, I click it, it goes to my wrapped gallery, and I am logged into gallery with the same account I was logged into geeklog with. Sweet.

So I guess, to summarize:

1. Install Geeklog.
2. Install layout theme.
3. Install Gallery
4. Install netpbm files into a directory in your base_dir path (or change your base_dir path, i guess)
5. Edit wrapper.header? (Not sure if this can be avoided somehow)
6. Edit theme's header.thml with a link to the directory.
7. GO THROUGH AND SECURE ALL THE INSTALLATIONS PER THE DOCS (chmod, delete directories, etc)

.:.Porkchop.:.
www.squalidlittlehobo.com
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Porkchop: This is how I installed gallery v1.4.1-pl1

There's your problem - that version is old and insecure.

You should have used at least Gallery 1.4.4-pl6 and I strongly encourage you to upgrade ASAP.

The bit about COM_siteHeader() that you ran into was because of a change in Geeklog at one point. Gallery has since been updated and 1.4.4-pl6 works "out of the box" without any further modifications.

bye, Dirk
 Quote

Status: offline

thefilmmaker

Forum User
Regular Poster
Registered: 10/18/04
Posts: 105
Will these steps stil work when trying to install the new versions of gallery?
 Quote

All times are EST. The time is now 04:59 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content