Welcome to Geeklog, Anonymous Monday, January 30 2023 @ 09:26 am EST

Geeklog Forums

erros on check.php


Bradster

Anonymous
I am working on installing geeklog on Centos 4. I get an error on the check.php webpage on my directories outside of the webservers folder.

Could not open error.log and access.log for writing.
Please check that you have set the logs directory and the files error.log and access.log in that directory to chmod 775.
Current permissions for logs: 775
Current permissions for error.log: 775
Current permissions for access.log: 775

I have checked, checked, and double checked my permissions and I am just at a loss. I've installed / reinstalled quite a few times with the same results. I've changed the permissions to 777 The site comes up ok. I've read the documentation so many times that I'm blue in the face. I'd be glad to give someone full access to see what I'm missing. This is just a test server and it will be reinstalled anyways.
 Quote

Status: offline

knuff

Forum User
Full Member
Registered: 12/17/04
Posts: 340
Location:Sweden
If 777 works fine, but 775 does not, this means that your webservers daemon does not belong to your current assigned group.

You have three options.

1. Change the owner to the http daemon (httpd).

Chown -R httpd log_directory
Chmod -R 775 log_directory
...

2. Add the httpd user to your current assigned group for these directories.

This could be something like depending on your flavor.

usermod -G yourgroup httpd

3. Assign 777.
Not really recommended.

Hopes this help.

Boris

Vanrillaer.com - our Family Portal
 Quote

Bradster

Anonymous
I appreciate the input, but when I said that I've changed the permissions to 777, I didn't mean that that fixed it. I still receive an error on the data and logs directories. I didn't mean that when I changed permissions to 777, the site comes up ok. I meant that everything works except for the errors I am receiving on check.php. So, the site does come up, I just cannot backup the database, get geeklog to write to the logs directory, ..etc. Sorry for the confusion.
 Quote

Bradster

Anonymous
By the way, this is how I did things. I setup the geeklog program in the /opts directory. I chowned apache:apache to geeklog and subdirectories. I copied the stuff in public_html to /var/www/html . This is running on Centos 4, which is a RHEL based OS. I just don't know what I am doing wrong.
 Quote

All times are EST. The time is now 09:26 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content