Welcome to Geeklog, Anonymous Monday, January 30 2023 @ 09:17 am EST

Geeklog Forums

line 114


Status: offline

affero

Forum User
Junior
Registered: 06/15/04
Posts: 25
Can anybody see anything wierd in the following?

Warning: main(/host/socaltic/system/databases/mysql.class.php): failed to open stream: No such file or directory in /home/socaltic/system/lib-database.php on line 114

Fatal error: main(): Failed opening required '/host/socaltic/system/databases/mysql.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/socaltic/system/lib-database.php on line 114

The install script won't install and I keep getting the above error. i have looked at everything in the config.php and the lib-common.php and it looks perfect. I have asked my host to check the database and it is working fine. My paths are correct because I have two other geeklog sites running on the same server. This is why i am so perplexed. I once again matched everthing and I get an error. I reinstalled my files, checked all my chmods and still the same error. any ideas?

thanks affero

http://rate.affero.net/creed/FSF/
 Quote

Status: offline

knuff

Forum User
Full Member
Registered: 12/17/04
Posts: 340
Location:Sweden
Hi Affero,

Are you sure it should be host and not home ?

/host/socaltic/system/databases/mysql.class.php
/home/socaltic/system/lib-database.php

Best Regards,
Boris
Vanrillaer.com - our Family Portal
 Quote

Status: offline

affero

Forum User
Junior
Registered: 06/15/04
Posts: 25
knuff/Boris,

i have been looking at that for hours and I honestly didn't see the host/home difference.

Now I truthfully don't know what to change and where? My other sites are host so i know that works. Where would I change the home to host?

Thanks affero-
http://rate.affero.net/creed/FSF/
 Quote

Status: offline

knuff

Forum User
Full Member
Registered: 12/17/04
Posts: 340
Location:Sweden
Hmm,

Getting confused here Mr. Green

From what I understand from the error you do have home and it can´t find host.

If you have SSH access (telnet) to your server, just do

ls -l /host/socaltic/system/databases/
ls -l /home/socaltic/system/


to make sure your paths are correct and the files are there.

With this error there is no need to reinstall. Just make sure the path is correct.


Best Regards,
Boris
Vanrillaer.com - our Family Portal
 Quote

Status: offline

affero

Forum User
Junior
Registered: 06/15/04
Posts: 25
Boris,

I switched it to home. Works perfectly. Thank for spotting that for me.

Cheers - affero
http://rate.affero.net/creed/FSF/
 Quote

All times are EST. The time is now 09:17 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content