Welcome to Geeklog, Anonymous Wednesday, April 17 2024 @ 12:28 pm EDT

Geeklog Forums

Need help: Almost installed...


Status: offline

geekgirl

Forum User
Newbie
Registered: 05/29/04
Posts: 10
Need some ideas.. here is what the check.php script gives me:

Parse error: parse error, unexpected T_CONSTANT_ENCAPSED_STRING in /usr/local/apache/www/TBTMradio.com/htdocs/geeklog/public_html/lib-common.php on line 4266
LBLBLBLBLBLB

Testing your Geeklog installation ...
LB

Testing logs directory ...
LBCould not open error.log and access.log for writing.
Please check that you have set the logs directory and the files error.log and access.log in that directory to chmod 775.LB
Warning: fileperms() [function.fileperms]: Stat failed for (errno=2 - No such file or directory) in /usr/local/apache/www/TBTMradio.com/htdocs/geeklog/public_html/admin/install/check.php on line 74

Warning: fileperms() [function.fileperms]: Stat failed for error.log (errno=2 - No such file or directory) in /usr/local/apache/www/TBTMradio.com/htdocs/geeklog/public_html/admin/install/check.php on line 75

Warning: fileperms() [function.fileperms]: Stat failed for access.log (errno=2 - No such file or directory) in /usr/local/apache/www/TBTMradio.com/htdocs/geeklog/public_html/admin/install/check.php on line 76
LBLBLBLB
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Sounds like a corrupted lib-common.php.

bye, Dirk
 Quote

Status: offline

geekgirl

Forum User
Newbie
Registered: 05/29/04
Posts: 10
thanks dirk... i'll try it!
 Quote

Status: offline

geekgirl

Forum User
Newbie
Registered: 05/29/04
Posts: 10
sad
no - didn't work. still does the same exact thing. even redownloaded the package. any other ideas?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
I still think your lib-common.php is corrupted.

Line 4266 itself is pretty harmless:
Text Formatted Code
$result = DB_query( $sql );
 


But the line before that is a very long line - maybe your text editor inserted some linebreaks into that line, which would explain that you get a parse error there.

Try using another text editor.

bye, Dirk
 Quote

Status: offline

geekgirl

Forum User
Newbie
Registered: 05/29/04
Posts: 10
happy
okay, dirk - you were right!

been using my mac with dreamweaver and i tried it several times with the same bad result. so to remove all doubt, i uploaded a vanilla lib-common.php and edited it with vi. it worked!
 Quote

All times are EDT. The time is now 12:28 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content