Welcome to Geeklog, Anonymous Sunday, December 04 2022 @ 05:40 pm EST

Geeklog Forums

Image error/File upload error solved....


Status: offline

jonimueller

Forum User
Junior
Registered: 11/28/02
Posts: 17
confused
I've tried searching this forum for answers, but the one person who had the problem and solved it didn't state how he solved it.

I finally figured out what the problem was. Even though the check.php output said that the CHMOD settings should be 775 on the /images/articles directory and the /backend directory, and the test indicated that the settings were indeed 775 on all those folders and files, I did have to change them to 777. I didn't have to do that on my other geeklog site, and that's why I was wondering why I was having so much trouble. Both sites are using the same web host and running on the same server (luna.affordablehost).

Perhaps it has something to do with the fact that this second site is actually a subdomain. Any thoughts on that? Once I CHMOD'd the folders and files to 777, however, it was happy as a clam. All's well that ends well, I suppose.

I'm putting the error message text in quotes so someone else can find this when they are searching.

Specified upload directory, /home/jmueller/public_html/zcoh/images/articles exists but is not writable



Plus, here's the original output from my check.php results:

Testing your Geeklog installation ...
Testing logs directory /home/jmueller/geekadmin/logs/ ...
logs directory and the error.log and access.log files are okay.

Testing backend directory /home/jmueller/public_html/zcoh/backend/ ...
Could not open the RDF file /home/jmueller/public_html/zcoh/backend/geeklog.rdf for writing.
Please check that you have set both the backend directory and the geeklog.rdf file in that directory to chmod 775. Current permissions for backend: 775
Current permissions for geeklog.rdf: 775


User photos are disabled - userphotos directory not tested.

Testing articles directory /home/jmueller/public_html/zcoh/images/articles/ ...
Could not write to /home/jmueller/public_html/zcoh/images/articles/.
Please make sure this directory exists and is set to chmod 775.
Current permissions for articles: 775

Results: 3 of 4 tests performed: 1 successful, 2 failed.



BTW, this is a test bed site for my car club. URL is
here.

Thanks!
My Geeklog Site:
http://www.ro-jo.net.com/geeklog/
 Quote

Matt

Anonymous
How do you change the CHMOD settings?
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 10/20/03
Posts: 807
Quote by Matt: How do you change the CHMOD settings?


Depends on your setup. Is your host using windows or linux? Do you have shell access, or only FTP access?
 Quote

All times are EST. The time is now 05:40 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content