Welcome to Geeklog Saturday, February 29 2020 @ 02:22 am EST

Geeklog Forums

Slow response?


Status: offline

barrywong

Forum User
Regular Poster
Registered: 12/04/02
Posts: 95
Over the last month, I have noticed a degradation of response when I log on to my Geeklog site as admin or as a user. What happens is that all the left blocks would appear (filling the entire screen), after that, it takes between 10-35 secs before the full site (left blocks, articles and right blocks) would appear. It happens every time I access the main page or topics in the Sections block. This response problem does not occur when I am not logged in as admin or user; (ie. anonymous visitor). It also does not happen when I am using User Functions, or any other of the blocks. Can any one tell me what is wrong. I have not added any new blocks or services. I have also cleared my PC cache and memory buffers. I tried doing a search on poor response but did not find any. Thank you.
 Quote

Status: offline

jimphelps

Forum User
Junior
Registered: 10/10/02
Posts: 20
We have noticed a gradual slow down on our Geeklog system too. We found that restarting mysqld causes the slow down to go away. We can actually watch the system slow down (log in on Monday, response times of 1.3 seconds. Tues 2.5 seconds, Wed 3.2, etc). We now have a nightly cron job running to restart mysqld. So. Try restarting mysqld and see what happens. - Jim
 Quote

Status: offline

rawdata

Forum User
Full Member
Registered: 17/02/03
Posts: 236
What do you have different on the pages for logged in users as opposed to anonymous ones? If you\'ve been doing updates or deletes on your site, have you been optimizing your tables?
 Quote

Status: offline

jimphelps

Forum User
Junior
Registered: 10/10/02
Posts: 20
Quote by rawdata: What do you have different on the pages for logged in users as opposed to anonymous ones?
Much more content for logged in users. We have 30 or so topics most of which you have to be logged in to see. We have about 20 groups to access the various topics (each topic is a project, each project has a team, each team is represented by a group).
Quote by rawdata: If you\'ve been doing updates or deletes on your site, have you been optimizing your tables?
Noooo.... We don\'t delete much. We add a lot of content. I haven\'t run any table optimization routines. I\'ll half to RTFM my MySQL manual for that one. - Jim
 Quote

Status: offline

barrywong

Forum User
Regular Poster
Registered: 12/04/02
Posts: 95
The difference between users vs anonymous visitors is that only users get to see forums, and so additional blocks that are created for them to access other applications. I disabled some of the blocks for being displayed but the response is still slow. I will try restarting mysql and see if that works. Thanks
 Quote

Status: offline

barrywong

Forum User
Regular Poster
Registered: 12/04/02
Posts: 95
Tried restarting mysql but it didn\'t improve response. I started disenabling some of the blocks and it appears to be Visitor stats plugin that slows down the speed of the site. Enabling it causes the response to slow down. Is anyone else encountering this? Does anyone know of any fixes or tweaking that will help? Thanks
 Quote

Status: offline

jimphelps

Forum User
Junior
Registered: 10/10/02
Posts: 20
That\'s interesting. We aren\'t running the Visitor stats plugin so we have different problems but maybe there is some underlying code issue. - Jim
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 08/01/03
Posts: 507
The stats pliugin is known to slow the site down.
 Quote

All times are EST. The time is now 02:22 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content