Welcome to Geeklog, Anonymous Monday, May 20 2024 @ 11:21 pm EDT

Geeklog Forums

CAN login [as admin] BUT CANT edit/add/change/delit


nick

Anonymous
worried
win2k localhost:80 php 4.2 apache 1.3 MySQL GL 1.3.8 register_globals = on ------------------------- whats wrong Frown . thanks
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 01/08/03
Posts: 507
See if this helps.
 Quote

nick

Anonymous
thanks i use ----------------------------------------------------------- $_CONF[\'cookiedomain\'] = \'.localhost\'; $_CONF[\'site_url\'] = \'http://localhost:80/geek/public_html\'; ----------------------------------------------------------- thats true? for example (of problem) http://localhost/geek/public_html/admin/link.php?mode=edit and http://localhost/geek/public_html/admin/link.php pages has same screen-link.php thanks.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Are you sure you have register_globals=on? That\'s the typical behaviour when it\'s off ... bye, Dirk
 Quote

nick

Anonymous
thanks! It works!
 Quote

JoeA

Anonymous
blank
OK, I have checked those things and see that they are set but still cannot post/change/delete etc.... Here\'s what I\'ve got: /etc/php.ini [snip] register_globals = On (after changing this variable to On i restarted the webserver.) /home/webroot/mydomain.com/geeklog/config.php [snip] $_CONF[\'cookiedomain\'] = \'.my.domain.com\' this is the path to the directory containing config.php $_CONF[\'path\'] = \'/home/webroot/mydomain.com/family/geeklog/\' $_CONF[\'site_url\'] = \'http://family.mydomain.com\' // $_CONF[\'path_html\'] = \'/path/to/your/public_html/\' $_CONF[\'path_html\'] = \'/home/webroot/mydomain.com/family/\' I moved the content out of public_html into a directory called family. Family is the root directory for my website which is mapped on the server to http://family.mydomain.com/. I can log in, create users, click around, but as in Nick\'s case cannot modify anything. I also set the log value to \"true\" for most of the geeklog files involved but haven\'t seen any indicative entries yet. Frown Thanks for any help, Joe
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by JoeA:I can log in, create users, click around, but as in Nick\'s case cannot modify anything.
So what happens if you try Nick\'s example above (link.php)? And are you sure you changed the right copy of php.ini? You may have more than one. Try calling up the install script again (just the first page). It should tell you in red writing if register_globals is still off. If it doesn\'t, then it\'s something else and we would need more information about your setup. bye, Dirk
 Quote

JoeA

Anonymous
Works now.... *phew* I just installed a new ver of php (php-4.3.3RC2), and replaced the old /etc/php.ini file with the new, setting register_globals = On and restarting my webserver, but THAT didn\'t work. I checked the install.php file as you recommended and sure enough the red writing told me it wasn\'t recognizing that line. What DID work was copying php.ini into a different directory as recommended in the INSTALL doc for PHP -- /usr/local/lib/php.ini After a quick restart the red text in install.php went away. *sigh* It was unclear to me where that elusive file was supposed to go, or how php knew where to look for it...now i know. Smile Thanks for your help! JoeA
 Quote

All times are EDT. The time is now 11:21 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content