Welcome to Geeklog, Anonymous Friday, April 12 2024 @ 11:45 am EDT

Geeklog Forums

1064 Error


Status: offline

bcbrock

Forum User
Chatty
Registered: 02/04/03
Posts: 64
While upgrading from 1.3.7sr2 to 1.3.8, I\'m getting the following onscreen:

\"1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \'= gl_comments.sid) AND (gl_stories.draft_flag = 0) AND (tid IN\"

In error.log, it records:

Tue Jul 22 09:36:27 2003 - 1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \'= gl_comments.sid) AND (gl_stories.draft_flag = 0) AND (tid IN SQL in question: SELECT DISTINCT count(*) AS dups, type, question, gl_stories.title, gl_stories.sid, qid, max(gl_comments.date) as lastdate FROM gl_comments LEFT JOIN gl_stories ON ((.sid = gl_comments.sid) AND (gl_stories.draft_flag = 0) AND (tid IN (\'Announcments\',\'FunFacts\',\'General\',\'Hints\'))) LEFT JOIN gl_pollquestions ON ((qid = gl_comments.sid)) WHERE (gl_comments.date >= (DATE_SUB(NOW(), INTERVAL 172800 SECOND))) AND ((((gl_stories.owner_id IS NOT NULL AND gl_stories.perm_owner IS NOT NULL) OR (gl_stories.group_id IS NOT NULL AND gl_stories.perm_group IS NOT NULL) OR (gl_stories.perm_members IS NOT NULL))) OR (((gl_pollquestions.owner_id IS NOT NULL AND gl_pollquestions.perm_owner IS NOT NULL) OR (gl_pollquestions.group_id IS NOT NULL AND gl_pollquestions.perm_group IS NOT NULL) OR (gl_pollquestions.perm_members IS NOT NULL)))) GROUP BY gl_comments.sid ORDER BY 7 DESC LIMIT 15

Any suggestions, please? Confused


~Brian
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by bcbrock:LEFT JOIN gl_stories ON ((.sid = gl_comments.sid) AND (gl_stories.draft_flag = 0) AND
The name of the table (gl_stories, in this case) is missing there in front of the \".sid\". But that\'s impossible, because it has the table name just before and after that point. Did you edit anything in lib-common.php (apart from the path to the config.php file)? bye, Dirk
 Quote

Status: offline

bcbrock

Forum User
Chatty
Registered: 02/04/03
Posts: 64
Dirk -

I didn\'t think I had changed anything but edit only the one line to the config file in lib-common.php, but at your mention of lib-common, I replaced it with a fresh copy, and tried again. This time, it worked. I must have accidentally hit a keystroke when I was editing the first time without realizing it.

Thank you very much for your help! Big Grin

~Brian


~Brian
 Quote

All times are EDT. The time is now 11:45 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content