Welcome to Geeklog, Anonymous Sunday, May 26 2024 @ 08:22 pm EDT

Geeklog Forums

External page plugin prob


Status: offline

alinford

Forum User
Regular Poster
Registered: 01/06/03
Posts: 96
I have everything worrking, however, in the External Plugin admin area, there is a spot that gets filled in with a link. This link is showing up like this: http://www.linford.net/gl/gl/genealogy/search.php It should be like this: http://www.linford.net/gl/genealogy/search.php This is what is automatically filling in the first time I go to a page. How do I fix this?
 Quote

Status: offline

tomw

Forum User
Full Member
Registered: 08/12/02
Posts: 300
The default templates take the file name from the variable $SCRIPT_NAME. As I said in the documentation, its best to fill this in with the actual name url of the page because the $SCRIPT_NAME variable sometimes does not get set correctly. I do not know whos problem this is PHPs or Apaches. The simple answer to your question is to fill in the correct url in place of substr($SCRIPT_NAME,1) in the file. You can then either edit the url so that is correct in the admin area or delete the entry and let it get created automagically. TomW
 Quote

Anonymous

Anonymous
Tom, that did not fix the prblem as it is still generating the same bad url. Where in the script is this url being generated? I am assuming that it is adding multiple variables together to create it. So I am wondering what the variables are and where they are stored.
 Quote

Anonymous

Anonymous
The url is generated from whatever you put in place of the variable. All the magic is done in the simple routine SEC_externalAccess in functions.inc. And that just takes the url that is passed to it. What does not work? Does it record hits and limit access? Where is the doubled url? You should not even have a complete url unless you are evaluating php pages for search. In other words, I am stumped, because urls are never created by the external access plugin. TomW
 Quote

Status: offline

alinford

Forum User
Regular Poster
Registered: 01/06/03
Posts: 96
Sorry for the confusion. When I click on the External Pages link in the Admin Only block, it show a list of the external pages. An example URL from there is: gl/genealogy/search.php This link, when clicked, goes here: http://linford.net/gl/gl/genealogy/search.php For some reason there is one gl too many. Since no one ever uses these links, who cares that they are a little screwed up. The problem is that, although hits are counted correctly, I can't limit access to the pages. The problems may be unrelated, but I was hooping that if I could fix the URL/Link issue, the acces issue would be solved as well. I have tried putting the file names into the variable area, but this has not helped so far.
 Quote

All times are EDT. The time is now 08:22 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content