Welcome to Geeklog, Anonymous Saturday, November 26 2022 @ 05:04 pm EST

Geeklog Forums

Problem with making geekages


Anonymous

Anonymous

I have just installed geekary, and it went fine. But when I try to make at new geekage, I get the following errors:

Warning: open_basedir restriction in effect. File is in wrong directory in /usr/www/we-knowhow_dk/public_html/geeklog/geekary/geekage_upload.php on line 271

Warning: getimagesize: Unable to open '/tmp/phpkn32FB' for reading. in /usr/www/we-knowhow_dk/public_html/geeklog/geekary/geekage_upload.php on line 271

Warning: open_basedir restriction in effect. File is in wrong directory in /usr/www/we-knowhow_dk/public_html/geeklog/geekary/geekage_upload.php on line 371

Could not create the necessary files. Contact your site administrator so they know there is a problem.

If anybody whats wrong please let me know

 Quote

Status: offline

vbgunz

Forum User
Full Member
Registered: 01/24/03
Posts: 169
Last I understood Geekages does not follow the same basic install procedure most plugins follow... In other words theirs more to configuring Geekages to work on your system than just placing its files in the right directories... Did you follow the install documentation to the period? Its not odd to think it works like others but their are a few requirements *unlike* others... Just double check your steps and try again. You'll get it. Good luck Smile---Victor B. Gonzalez
Victor B. Gonzalez -
http://aeonserv.com
 Quote

Anonymous

Anonymous
I followed the installation process given with the distribution. I have just found out that I get the same errors in upload.class.php, it is always when I use the functions getimagesize or copy. I don't think it is the installation but some kind of server restriction.
 Quote

Status: offline

ndarlow

Forum User
Junior
Registered: 06/30/02
Posts: 31
Your service provider has enforced security on where PHP can access files by use of the open_basedir setting. This means that any upload directories must reside below the directory specified by the open_basedir setting. For a vanilla PHP installation uploads default to the system-wide temporary directory e.g. /tmp/ which will violate the open_basedir restriction. The simplest way to remedy this is either to run your own little phpinfo script (or use phpMyAdmin's if it's installed and that feature is enabled) to determine the setting of open_basedir that applies to your webroot. Having done this, adjust your Geeklog and Geekary upload directories to be located at the same level, or below, the open_basedir value reported by phpinfo. Regards, Neil Darlow M.Sc.
 Quote

liquid

Anonymous
I think I figured out how to solve the problem, I have to move the uploaded file with move_uploaded_file(); and then operate on the new file. But it requires some hacking :-)
 Quote

Status: offline

jhk

Forum User
Chatty
Registered: 07/13/02
Posts: 57
I ran Geekager for a month or so before I gave up on it. It has some nice functionality but it was too confusing for other users and they couldn't find the images below the top level. I switched to the 4images (integration by Gplugs) which is a lot easier for users to work with. It requires some initial hacking of files but nothing excessive. And it looks and works better, again in my opinion. Cheers, Jens
 Quote

Status: offline

4Xsample

Forum User
Junior
Registered: 09/21/03
Posts: 26
In my site I have problems making geekages too. I get no errors simply theres no send buton... I have only the preview buton... so I cant send

and I have a secondary problem but I think Ill solve it by myself if I can is that I cant view the images edit and geekage under the image
 Quote

All times are EST. The time is now 05:04 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content