Welcome to Geeklog, Anonymous Saturday, June 03 2023 @ 01:17 pm EDT

Geeklog Forums

Page width problems


Status: offline

nightvision

Forum User
Junior
Registered: 03/20/03
Posts: 20
I am having problems with the width of a page that is displayed depending on who is logged in. I am using a static page titled frontpage, so it appears on the front page of my site and have created what looks like a center block. It has a title in it. When different people log in, the width of the entire page will vary. Sometimes it will become smaller. When this happens, the center block that i created becomes squooshed together.

the way i have it right now, when you go to my site, it looks fine. if I log in as admin, it looks fine. if I post a new story, it looks fine when logged in as admin, but when i logout, it is squooshed. If I log in as a test user, it is squooshed.

you can see what I mean at my site:

www.40thoz.vze.com

username - test
password - test

does anyone know why the width would change from user to user??

Any help would be greatly appreciated.
 Quote

Status: offline

rawdata

Forum User
Full Member
Registered: 02/17/03
Posts: 236
I'm not sure why it doesn't display squished all the time. You have five columns in that block. One is set at 80% and another at 20% leaving no room for the other three columns. You also have a row with one column set at 100% leaving no room for the remaining two columns. Try making your columns in each row add up to no more than 100% and see if that fixes it.
 Quote

Status: offline

nightvision

Forum User
Junior
Registered: 03/20/03
Posts: 20
Hey Rawdata, thanks for the response. I took the front page out totally and i still get a squooshing and it seems as if it is shifting somewhat to the right. This had been workign fine for all users. I tried tracing back all changes that I made to the site and nothing seems to fix it.
 Quote

Status: offline

nightvision

Forum User
Junior
Registered: 03/20/03
Posts: 20
When i view anything as admin, it looks perfect. When I login as any user, things get squooshed. I tried adding a user to the admin group and that did not fix my problem. What does this admin account have that all other accounts do not??
 Quote

Status: offline

rawdata

Forum User
Full Member
Registered: 02/17/03
Posts: 236
POWER!! hehehe I don't know why you would be seeing two different views of the same page unless one is an older cache version and the other is not. Here try this instead. Run your page through the HTML validator here: http://validator.w3.org/ and fix the errors. You've got a bunch of them, but at least fix unmatched and misplaced tags. You have more of a chance of it looking right when the page validates than if it doesn't.
 Quote

Status: offline

nightvision

Forum User
Junior
Registered: 03/20/03
Posts: 20
hey rawdata, this is what i have discovered after restoring some backups. For some reason, everything works fine until I hit 15 stories. When I have 14 stories on the page, everything is perfect. Once I get that 15th story in there, the pages start to get squooshed. Do you know what could be happening at 15?
 Quote

Status: offline

nightvision

Forum User
Junior
Registered: 03/20/03
Posts: 20
From running some more tests, I have found that if i set limitnews in config.php to 5, I can post 14 stories. As soon as I post the 15th, everything gets squooshed. If I change limitnews to 10, I can post 19 and the 20th gets squooshed. If I set the limitnews to a number much higher then the amount of pages I have, this works fine. The problem is, I only want 5 stories per page to show. When I go into the topics section and set the stories/page, no matter what I set that to, they have no effect. Am I doing something wrong? Are older pages suppossed to archive or something? What can I do to fix this? Thanks in advance!!
 Quote

Status: offline

rawdata

Forum User
Full Member
Registered: 02/17/03
Posts: 236
Go back and try one of GL's default themes and see if you get the same thing happening. If not, then it's errors in your theme.
 Quote

Status: offline

nightvision

Forum User
Junior
Registered: 03/20/03
Posts: 20
I tried the default xsilver theme and get the same problem. For some reason when the stories get to be one less then limitnews is equal to, the page shrinks. I have no idea where to go from here.
 Quote

Status: offline

nightvision

Forum User
Junior
Registered: 03/20/03
Posts: 20
Oops, I meant to say that when the amount of stories 3 times the limitnews, this happens. If it is 1 less then 3 times the limitnews it works fine. so if i have limitnews set to 5, 15 stories cause this problem. yet 14 stories work fine.
 Quote

Status: offline

rawdata

Forum User
Full Member
Registered: 02/17/03
Posts: 236
Why don't you create this situation again and save the page. Then post a link to it.
 Quote

Anonymous

Anonymous
hey rawdata, this is what I have figured out so far. The problem definately has something to do with the amount of stories one can view per page. If the amount of stories is x (x changes based on how many stories are set in limit news) times the amount a user is setup to view per page, the squooshing occurs. The reason some users would see this problem and others wouldn't is because some user profiles are setup to view a different amount of stories (all dependant upon wether the account was setup before or after limitnews was changed from the default or if someone manually changed it). For troubleshooting, I have set the limitnews to 10, so that this problem will not occur when a user is not logged. I currently have 15 stories. If this amount would get to 20, this problem would start to happen. Not only is my frontpage (staticpage)becoming smaller, but the story tables as well. I have created a test account that is setup to only view 5 stories per page. When you log in as test: username - test password - test yo will see what I mean. Again, the address is http://40thoz.dynu.com:3385/new. Thanks again!! I hope i illustrated the problem clearly for you.
 Quote

Status: offline

rawdata

Forum User
Full Member
Registered: 02/17/03
Posts: 236
After looking at the two, I can't pinpoint it. I still think it's caused by forcing too much info into rows plus the theme having some unmatched and misplaced tags. Perhaps the browser is merely reacting to some sort of compounding effect of these. If you don't want to spend the time fixing them, then I recommend just shorten the title.
 Quote

Status: offline

nightvision

Forum User
Junior
Registered: 03/20/03
Posts: 20
Thanks for trying! What I have decided to do is make that frontpage (staticpage) an image since the data doesn't change. That will force the the story tables to be at least as big as that graphic. The only problem with that, is if a story title is larger then the graphic, the stories will be larger and the graphic will look funny. I will just keep all of the titles small. What HTML errors are you referring to? The one's in the front page static page or on index.php? I was not sure what to run through that generator. Thanks again!!
 Quote

All times are EDT. The time is now 01:17 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content