Welcome to Geeklog, Anonymous Saturday, July 13 2024 @ 11:30 am EDT

Geeklog Forums

Help ?


Status: offline

dlcheetham

Forum User
Newbie
Registered: 04/04/02
Posts: 7
Hi,

Geeklog was working fine, then in my wisdom (?) I decided to upgrade my environment. First I switched from Win2000 to XP. Then I upgraded all the major components as follows

Apache 2.0.42
MySQL 4.0.12
PHP 4.3.1

I started up local copy of geeklog and got a message complaining about my sql syntax.
1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE name = 'whosonline_block'' at line 1
After a lot of messing about I have traced this to the fact that the globals are not set up in lib_common.php so the table name in the call to 'DB_getItem' is empty.
I have proved this by inserting the line 'global $_TABLES' at the top of lib_common.php.
It solves that problem, but opens up another hornets nest of issues.

Any ideas ? I'm well and truely stumped.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Are you sure you have register_globals = on in your php.ini? bye, Dirk
 Quote

Status: offline

dlcheetham

Forum User
Newbie
Registered: 04/04/02
Posts: 7
It was not on by default, but I had been warned about that so I set it manually. - No help. Any other ideas ?
 Quote

Anonymous

Anonymous
your trying to run it on WindowsXP ? hmm maybe I read this wrong I have not tried this yet, and I dont know if xp is the correct "server" enviroment I know Windows2000 Server is.. But anyway double check everything in the php.ini make sure the paths are still the same if the paths changed, like where php was install, where MySQL was installed and very important to double chech the IIS server settings, make sure you have a pointer back to php.exe if all these are correct and double checked, then you run into an Issue that WinXP has some starng default setting for IIS and the way it blocks certain area's. If all else fails replace the Apache 2 with 1.3 and I bet it will work. Been there done that. :-)
 Quote

Anonymous

Anonymous
I'm running it on Apache 1.3.26 php 4.3.1 [globals on or off] MySQL 3.x and I'm having a lot of problems with the Calendar mostly.
 Quote

All times are EDT. The time is now 11:30 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content