Welcome to Geeklog Friday, September 25 2020 @ 11:06 pm EDT

Geeklog Forums

Can't login as NewAdmin


Status: offline

sakata

Forum User
Junior
Registered: 17/12/01
Posts: 25
Location:Japan
A HAPPY NEW YEAR! I am trying to use Geeklog in Japanese, I can send you the japanese.php soon. Well, I have tried to upgrade Geeklog 1.3 from 1.2.5-1. But I cannot login as NewAdmin. Geeklog says, 'mysql_errno: You have an error in your SQL syntax near '' at line 1'. Can anyone explain what happens here? I can login other username.
 Quote

Status: offline

Tony

Site Admin
Admin
Registered: 17/12/01
Posts: 405
Location:Urbandale, Iowa
First, and most obvious, make sure the NewAdmin user is in the users table. If it is then make sure the NewAdmin user ID has records in the userprefs, userindex and usercomment tables. Post a response if that works.
The reason people blame things on previous generations is that there's only one other choice.
 Quote

Status: offline

sakata

Forum User
Junior
Registered: 17/12/01
Posts: 25
Location:Japan
At First, I made a new admin user as explained in 'Manually Creating a Geeklog Superuser'. And it works fine, thanks. About the 'NewAdmin', I report the result. 1:There are 'NewAdmin' in users table with uid 15. 2:There are no uid=15 record in usercomment, userindex, userprefs and userinfo tables. 3:Instead of uid=15, there are uid=-1 in those tables. 4:There are no user with uid=-1 in users table. Thank you verry much! My environment is as follows. OS:Linux 2.4.9 (Debian Woddy) Mysql:Ver 11.13 Distrib 3.23.36 Apache:1.3.22
 Quote

All times are EDT. The time is now 11:06 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content