Welcome to Geeklog Sunday, September 24 2017 @ 01:01 am EDT


Status: offline

masodo

Forum User
Junior
Registered: 13/11/2012
Posts: 34
Location:Indiana US
I just updated my site to 2.1.2 from 1.8.1 and installed Ban 2.0.1 (among other things) and am having some trouble restoring some custom functionality I had with the old site.

Back in the good old days Wink I would have the banned individuals redirected to a special page (http://BlogDogIt.com/errors/BlogDogIt403.php) This page would display their address and instruct them to click on the displayed IP to request removal from the ban list (since I tend to be heavy-handed with the IP Range blocks I have been known to block-out my friends on occasion)

I found that opening the "error" folder to allow from all via .htaccess they were able to at least gain access to those scripts.

Nowadays however, no matter what I try I cannot get the redirect to do anything other than a refresh loop. I read the caution in /admin/plugins/ban/readme.html and have tried using the example "GO AWAY" html page but same deal. I have tried entering an address to another domain even, but cannot get past the refresh loop (which the readme.html typo-ly terms "refresh look" - btw)

So I guess I am unclear as to exactly where should I place the custom 403 message on the site so it is not considered "one of our Geeklog Pages" so as to avoid the loop. I had thought if I could no longer run my php scripts (which I was thinking I could possibly white list them for access) then perhaps I could redirect to an off-site location using a meta refresh in the go-away page.

Any help would be appreciated - If I figure something out I'll let you know.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1227
You found a bug! Big Grin

I fixed it at Github

Or you can open up functions.inc in a text editor in the plugins/ban/ directory and update line 713 too:

PHP Formatted Code
echo COM_redirect($_BAN_CONF['page']);


What was happening was the ban configuration page value was not being used and just an empty variable was being passed which resulted in the loop.

Thanks for the report.
One of the Geeklog Core Developers.

Status: offline

masodo

Forum User
Junior
Registered: 13/11/2012
Posts: 34
Location:Indiana US
happy
BINGO!

Hey, thanks for the prompt fix on this Laugh!
~~Patch applied~~
Once more a happy camper - me Big Grin

All times are EDT. The time is now 01:01 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content