Welcome to Geeklog Sunday, August 20 2017 @ 08:46 pm EDT


Andy

Anonymous
Is there any effort to make 1.8.x compatible with php7? I would like to use the newspaper theme, but it requires 1.8, which only works on ubuntu 14.04 (which is no longer supported).

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1226
The short answer is No. There have been to many fixes and changes since then.

Upgrading to Geeklog 2.1.1 (or 2.1.2 which is due out soon) is a better option and then upgrading the newspaper theme to support 2.1.1 (which would be much easier for someone to do).
One of the Geeklog Core Developers.

Andy

Anonymous
awake
Quote by: Laugh

The short answer is No. There have been to many fixes and changes since then.



Ok, I understand. I may take on this effort. I looked at the theme creation documentation. It looks like it covers 2.0.x. Is that right? Will the current themes description document contain all I need to convert the old theme to the new?

Thanks!

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1226
It should...

I would use the professional theme as a comparison from Geeklog 2.1.1 as you build it since it is probably the closest theme to the newspaper if I remember it correctly. (or start with the professional and convert it to the newspaper)

Geeklog 2.1.1 doesn't support PHP 7 but Geeklog 2.1.2 does so at some point you will have to update to 2.1.2. The Professional theme is not part of 2.1.2 but there are not to many changes from going to 2.1.1 to 2.1.2 for the themes.
One of the Geeklog Core Developers.

All times are EDT. The time is now 08:46 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content