Welcome to Geeklog Friday, July 03 2020 @ 11:47 pm EDT

Geeklog Forums

Stories not appearing for non-logged in

Page navigation


Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
I recently upgraded from 1.3x to 2.0, when a user submits a new story, I noticed that the perm_anon value is now "0" instead of "2" like our old version entered in the MySQL table. I tracked that down as the cause of the stories not appearing on the homepage of non logged in users. I checked the topic permissions and config and both allow for annoymous users to view. If I go in and modify this value back to 2, they appear. But how can I fix the cause of this?

I noticed these other values are also changed (most are now "0", compared to our old version:
group_id (seems to not matter)
perm_owner (must be "3" or other members logged in can't see)
perm_group (must be "3" or other members logged in can't see)
perm_members (must be "2" or other members logged in can't see)
 Quote

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1398
Hmmm, there is a similar bug report:

http://project.geeklog.net/tracking/view.php?id=1726

I can't seem to reproduce the error. Are your Default Story Permissions set correctly?

Check the Configuration under Miscellaneous and the Tab Permissions. The default for Story, Topic and Block are:

Read-Write
Read-Only
Read-Only
Read-Only


One of the Geeklog Core Developers.
 Quote

Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
I don't see permissions under miscellaneous or tab in configuration interface
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Normally you should find the tabs:

Cookies
Miscellaneous
Debug
Daily Digest
HTML Filtering
Censoring
IP Lookup
Permissions
Webservices
Topics

under Miscellaneous in the config

Do you use a default theme bundle with Geeklog 2.0?

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
Oh, I see it now, it was under "more"
This is what my permissions page shows:

Story/Topic/Block Default Permissions[0] Read-Write
Story/Topic/Block Default Permissions[1] Read-Only
Story/Topic/Block Default Permissions[2] Read-Only
Story/Topic/Block Default Permissions[3] Read-Only

The autotags all say "use"

One other thing I noticed is that when I went to edit older stories (pre upgrade) they are owned by "topic admin" but the new stories are all owned by "all users"
 Quote

Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
Not sure if this helps any, but I tried switching out the themes and submitting via the front end and all of them do this. Hoping there is some solution to this problem. I also have my posts not held for moderation (auto posts) if that information is of any help.
 Quote

Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
Anyone else have any ideas?
 Quote

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1398
If you save the stories with the correct default permissions:

Group: Story Admin
Permissions: All checked except Group Edit

Can non-logged in users see the stories?


One of the Geeklog Core Developers.
 Quote

Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
Yes, if i go in and do that (which is how I'm keeping the site going now, doing that manually each time a submission comes in) then they appear correctly, even to guest (non logged in) users.
 Quote

Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
Is it OK to post this as a new thread to see if anyone else might have some ideas for us? We're pretty desperate
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Hi,

I can't reproduce the issue on the Geeklog 2.0 demo site.

I also have my posts not held for moderation (auto posts) if that information is of any help.


In your config, under Users and Submissions > Submissions settings, is Story Submission Queue is set to true?

Can you provide me a private link to check this issue?

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1398
If you can't solve it Ben we will need to get the database jason559 to take a look as we cannot reproduce the issue here. (though one other Geeklog user has had the same issue)

One thing to check is if the "Story Admin" exists? and if it has the "story.edit" right enabled.

The story permissions are grabbed right from $_CONF['default_permissions_story'] when the story is created and if that is set in the configuration properly I am not sure really what is going on here.

jason559 what language(s) is your site setup for?

One of the Geeklog Core Developers.
 Quote

Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
Quote by: ::Ben

Hi,

I can't reproduce the issue on the Geeklog 2.0 demo site.

I also have my posts not held for moderation (auto posts) if that information is of any help.


In your config, under Users and Submissions > Submissions settings, is Story Submission Queue is set to true?

Can you provide me a private link to check this issue?

Ben



Story Submission Queue is set to false, I will PM you Ben, thank you.
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Story Submission Queue is set to false, I will PM you Ben, thank you.


PM received but sorry I do not want to look at your content. I hope you understand.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
Quote by: Laugh

If you can't solve it Ben we will need to get the database jason559 to take a look as we cannot reproduce the issue here. (though one other Geeklog user has had the same issue)

One thing to check is if the "Story Admin" exists? and if it has the "story.edit" right enabled.

The story permissions are grabbed right from $_CONF['default_permissions_story'] when the story is created and if that is set in the configuration properly I am not sure really what is going on here.

jason559 what language(s) is your site setup for?



I'm guessing the problem might have happened during the upgrade, I think we were on 1.3.6 before, but not certain.
I went to "Group Listing", which I assume that's where Story Admin would be. It doesn't show up in the listing, but if I click "Show Admin Groups" and click submit, it does appear.
It is not the "default group" and there are non as default it appears
Security groups on it is listed as "all users"
and under "Rights" it shows
(story.edit)
(story.moderate)
(story.ping)
 Quote

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1398
I should have asked this before... what theme are you using? Is it one of the ones that ship with Geeklog 2.0.0? (if not try one of those to see if it fixes the problem)
One of the Geeklog Core Developers.
 Quote

Status: offline

jason559

Forum User
Regular Poster
Registered: 31/03/03
Posts: 81
Sorry for the delay, I'm currently using the theme/template "Denim" but I did try the other two as well and they have the same problem.
I also disabled our plugins to test if they may be interfering, that didn't help.
 Quote

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1398
Is your site Multilanguage?

I don't think I can do much more unless I get a copy of your database so I can reproduce the error on my end and step through the code. If you are willing to email me your database I will take a look in the next week or so. I would delete the database once I had finished my testing.

Let me know by sending an email through Geeklog.net
One of the Geeklog Core Developers.
 Quote

Status: offline

ivy

Forum User
Full Member
Registered: 25/11/04
Posts: 313
Location:Tokyo Japan
gl_topic_assignments is new table from Geeklog 2.0 for topic relations.
I troubled at Static page same problem before.

Geeklog Japan https://www.geeklog.jp
 Quote

me

Anonymous
It happen to me as well, new install of gl2.0. I have couple site before it working good. waiting!
 Quote

Page navigation

All times are EDT. The time is now 11:47 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content