Welcome to Geeklog Sunday, October 24 2021 @ 02:53 pm EDT

Geeklog Forums

Some Menu Items Have a Transparent Background


Status: offline

gtgillis

Forum User
Full Member
Registered: 05/11/03
Posts: 121
Location:Spring, TX
I installed Menu 1.0. I have the navigation menu active and I see the menu. The problem is the drop down elements. Only the first one has the background color I selected, all the other ones below it have a transparent background which makes it very hard to see.
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Hi Greg,

What is the theme you used ?
Can you test this issue with another theme ?

I confirm some css issues with modern curve theme.

Ben


I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

gtgillis

Forum User
Full Member
Registered: 05/11/03
Posts: 121
Location:Spring, TX
I was using the Professional theme. I just tried it with Denim and got the same result.
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Can you provide me a link because I see no issue on my local test site ?

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

gtgillis

Forum User
Full Member
Registered: 05/11/03
Posts: 121
Location:Spring, TX
It was actually Professional and Winkey12 that I see the transparent background.

Denim and Modern curve work fine.

My site is www.sillig.com. I currently have it set to the professional theme. Look at the black menu above my logo
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
What is the color you set for the submenu?
Menu Options for navigation > Menu Color Options > Sub Menu BG

and do you use graphics or colors
Menu Options for navigation > Menu Graphics > Use Graphics or Colors?

Thanks,

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

gtgillis

Forum User
Full Member
Registered: 05/11/03
Posts: 121
Location:Spring, TX
I set the sub Menu BG to black. I have tried blue, green and red.

I have it set to use colors not graphics.

The first element in the drop down has the correct BG color but all others underneath it are transparent.
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
I see also in the css the use of an url for an image (/images/menu/menu_hover_bg.gif) that do not exist, but if you tell me you set to color and not graphics I don't know with the url is there. As the css are cached, maybe it is a cache issue. Can you try to delete the files from the cache folder data/menu/cache

Thanks,

Ben


I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

gtgillis

Forum User
Full Member
Registered: 05/11/03
Posts: 121
Location:Spring, TX
I deleted the files from /data/menu/cache/english but it had no effect.
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
I don't know what to tell you. I can't reproduce this issue on my local demo site.

I installed a fresh professionnal theme and replace

PHP Formatted Code
<div class="header-navigation-container clearfix">
        <ul>
            {menu_elements}
        </ul>
    </div>

by

PHP Formatted Code
<div class="clearfix">
        {header_navigation}
    </div>

in public_html/layout/professional/header.thtml file
and menu is render like this.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

gtgillis

Forum User
Full Member
Registered: 05/11/03
Posts: 121
Location:Spring, TX
I still had the header-navigation-container in the div class. I removed it and it works fine. Sorry for the run around.
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Nice that we solved this issue Big Grin

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

All times are EDT. The time is now 02:53 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content