Welcome to Geeklog Wednesday, June 26 2019 @ 08:43 pm EDT

Geeklog Forums

GL 2.0.0rc2 plugin problems


Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1294
I updated an older site with GL 1.6.0sr2, all plugins were activated. Now in GL 2.0.0rc2 I find many plugins "unresolved 2.0.0 unavailable" especially static pages. What can I do?

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
Besides the Staticpages, which plugins?
One of the Geeklog Core Developers.

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1294
Links Polls Calendar show the same problems.

XMLSitemap, Bad Behavior2, Spam-X show no problems.

Those have been set to uninstalled plugins:

Captcha "OK- Die Lade-Reihenfolge von einem oder mehrere Plugins wurde geändert, um Abhängigkeiten aufzulösen."
If I click install: "Fatal error: Call to a member function fetch_array() on a non-object in /www/geeklog/system/databases/mysqli.class.php on line 653"

GUS: "OK- Die Lade-Reihenfolge von einem oder mehrere Plugins wurde geändert, um Abhängigkeiten aufzulösen."
If I click install: "2 - get_class() expects parameter 1 to be object, boolean given @ /www/geeklog/system/databases/mysqli.class.php line 543

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1294
o.k., I just had an idea and changed the siteconfig.php to

define('VERSION', '2.0.0' ) before I had: define('VERSION', '2.0.0rc2' )

Now the plugins work apart from Captcha 3.3.0 and gus. Maybe I have old versions? Where are the ones working with GL 2.0.0rc2 ?

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Can you try Captcha 3.3.1?

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
There is also a Gus 1.7.0 available.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
Quote by: 1000ideen

o.k., I just had an idea and changed the siteconfig.php to

define('VERSION', '2.0.0' ) before I had: define('VERSION', '2.0.0rc2' )



Did the install set 2.0.0rc2?

Captcha works on Geeklog 2.0.0.

Gus will probably fail duing install since it adds a block I believe. I will have to test this.
One of the Geeklog Core Developers.

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1294
Thanks, but it does not work! Same errors as before. BTW Gus does not show version number.

---------------
no I set rc2 manually to keep an overview Monkey

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
Captcha 3.3.1 Installs fine on Geeklog 2.0.0. It is installed on Geeklog.net and on my development server.

I see your error mentions mysqli. Maybe that has something to do with it... we will have to check it out.
One of the Geeklog Core Developers.

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1294
On my second webspace I get the following warning during the installation when updating an older GL 1.6.2sr2 to 2.0.0rc2

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/www/xxx/db-config.php) is not within the allowed path(s): (/www/xxx/httpdocs:/tmp) in /www/xxx/admin/install/index.php on line 1032

Then further on:
Fatal error: Call to undefined function MBYTE_strlen() in /www/blabla/system/lib-plugins.php on line 1650


As far as I read the function mb_strlen() is not enabled by default in PHP.

Any ideas?

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
Hmmm I have never heard of open_basedir restriction before. I did a quick google search and see that it is a PHP ini option (http://php.net/manual/en/ini.core.php). Here is a quote from another page:

PHP open_basedir protection tweak is a Safe Mode security measure that prevents users from opening files or scripts located outside of their home directory with PHP, unless the folder has specifically excluded.


It seems you will have to disable open_basedir or include the directories that Geeklog needs to access that are outside of the web root.

With mb_strlen you need the PHP mbstring extension loaded.
One of the Geeklog Core Developers.

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1294
o.k., that was my problematic webspace #2 with "open_basedir restriction" though it had no problem updating to 1.8.2sr1.

Let`s concentrate on the other one. The mysqli problem is this new with GL 2?

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
Yes mysqli is new to Geeklog 2.0.0

It should be faster than the regular mysql extension.

My development server doesn't have mysqli installed so I haven't put it through it's paces yet. I will have to reach out to Geeklog jp to see what they say about the problem.
One of the Geeklog Core Developers.

Status: offline

mystral-kk

Site Admin
Admin
Registered: 19/03/06
Posts: 100
Location:Japan
GUS uses mysql_* functions along with DB_* functions, so I don't think it will work with Geeklog-2.0.0 if mysqli extension is enabled. Till GUS is updated to work properly with GL-2.0.0, you should disable mysqli extension.
-- mystral-kk, "Every cloud has a silver lining."

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1294
Just as a reminder, GUS and Captcha does not work with me.

Would the developer of GUS think about the following: It would be nice to have 2 separate rights. One for seeing the stats like "today" and one for operating the adjustments.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
I will be providing an update to GUS soon after Geeklog 2.0.0 is released which will fix any issues.
One of the Geeklog Core Developers.

Status: offline

mystral-kk

Site Admin
Admin
Registered: 19/03/06
Posts: 100
Location:Japan
Quote by: Laugh

I will be providing an update to GUS soon after Geeklog 2.0.0 is released which will fix any issues.

Laugh, I have updated GUS and confirmed it works with GL-2.0.0(RC3). Is it OK if I import the updated version into the repository at https://code.google.com/p/geeklog/?


-- mystral-kk, "Every cloud has a silver lining."

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
Yes go ahead. I haven't done much yet except work on the autoinstall. Did you make the GUS block dynamic?

Tom
One of the Geeklog Core Developers.

Status: offline

mystral-kk

Site Admin
Admin
Registered: 19/03/06
Posts: 100
Location:Japan
Quote by: Laugh

Yes go ahead. I haven't done much yet except work on the autoinstall. Did you make the GUS block dynamic? Tom

No, I just replaced mysql_* functions with DB_* functions and ereg(i) functions with preg_match, and GUS installed with GL-2.0.0(RC3).


-- mystral-kk, "Every cloud has a silver lining."

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
Sounds good. I haven't looked to closely at GUS yet anyways.
One of the Geeklog Core Developers.

All times are EDT. The time is now 08:43 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content