Welcome to Geeklog Sunday, July 21 2019 @ 02:37 am EDT

Geeklog Forums

Problems with jquery


Status: offline

alb3rt

Forum User
Chatty
Registered: 30/10/06
Posts: 61
Location:Mexico City
blank
Hello,

I tried to install or migrate geeklog on a server, but I appear some strange errors with jquery.

In my local server works fine, but when I try to migrate or even make a new install I have problems with jquery, because not all scripts load.

For example in the footer on my local server I have this:
PHP Formatted Code

<script type="text/javascript">
var geeklogEditorBaseUrl = 'http://ime.dws';
</script>
<script type="text/javascript" src="http://ime.dws/javascript/common.js"></script>
<script type="text/javascript" src="http://ime.dws/javascript/jquery.min.js"></script>
<script type="text/javascript" src="http://ime.dws/javascript/jquery_ui/jquery.ui.core.min.js"></script>
<script type="text/javascript" src="http://ime.dws/javascript/jquery_ui/jquery.ui.widget.min.js"></script>
<script type="text/javascript" src="http://ime.dws/javascript/jquery_ui/jquery.ui.position.min.js"></script>
<script type="text/javascript" src="http://ime.dws/javascript/jquery_ui/jquery.ui.mouse.min.js"></script>
<script type="text/javascript" src="http://ime.dws/javascript/jquery_ui/jquery.ui.autocomplete.min.js"></script>
<script type="text/javascript" src="http://ime.dws/javascript/jquery_ui/jquery.ui.tabs.min.js"></script>
<script type="text/javascript">document.getElementById("geeklog_config_editor").style.display="";</script>
<script type="text/javascript">var autocomplete_data ....
 




And on the other server, I have only:
PHP Formatted Code

<script type="text/javascript" src="http://www.ime.uia.mx/javascript/jquery.min.js"></script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.11/jquery-ui.min.js"></script>
<script type="text/javascript" src="http://www.ime.uia.mx/javascript/common.js"></script>
<script type="text/javascript">document.getElementById("geeklog_config_editor").style.display="";</script>
<script type="text/javascript">var autocomplete_data ...
 


I don't understand why query.ui.core.min.js and the others are not charged. I have Use CDN-hosted copy of jQuery (?) False. I use GL 1.8.1.
D Web Studio - www.d-webstudio.net

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1356
Do things work if CDN-hosted copy of jQuery is set to true?

Only the jQuery scripts needed are loaded. Your first example looks like it was taken from the Geeklog Configuration page. Your second example could have been taken from the home page.

Tom

PS: You had 4 duplicate forum posts on this problem so I deleted 3 of them.
One of the Geeklog Core Developers.

All times are EDT. The time is now 02:37 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content