Welcome to Geeklog Wednesday, March 20 2019 @ 12:59 am EDT

Geeklog Forums

Installing Geeklog 1.8.1 for the first time


Firstime_Geeklog_User

Anonymous
determined
Hi,

I just installed Geeklog 1.8.1 onto a Linux Red Hat 5.5 Server. The installation script had http://mywebsite as site_url and http://mywebsite/admin as the site_admin_url. The installation went well and it allowed me to change the default password for Admin. However, nothing on the left side under Admins Only is working - except Users and Trackback. It seems to be missing the site_admin_url of http://mywebsite/admin. Manually inserting the admin directory into the url brings up the page but I can not save it because I get a 404 Not Found error.

Any ideas how to fix it? I'm sure it is just a simple thing but I'm at a loss here.

Please help!

Best Regards,

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Anonymous

It seems to be missing the site_admin_url of http://mywebsite/admin. Manually inserting the admin directory into the url brings up the page but I can not save it because I get a 404 Not Found error.


This sure sounds odd, especially since some of the admin options seem to be working for you.

Can you confirm that it really is using the wrong site_admin_url, please? See if you can get to http://mywebsite/admin/configuration.php The second entry listed on that page is the "Admin URL". What does it say?

If it's wrong, you could either try reinstalling (since you probably couldn't really do anything with the site anyway) - drop the database, create a new empty one and run the install script again. Alternatively, you could try the Geeklog Emergency Rescue Tool, which lets you change some of the settings.

If, however, the Admin URL listed is correct, your problem may be elsewhere. For example, on some hosts, the /admin URL is used to manage the server which may conflict with Geeklog. In that case, you could rename the entire "admin" directory to something else, e.g. "myadmin", and change the URL accordingly (see above).

Let us know how it goes.

bye, Dirk

Firstime_Geeklog_User

Anonymous
excited
Hi,

I followed your suggestion to drop and recreate the database. Afterwards, I reran the installation script and realized that I had made a typo. I took the default http://mywebsite/admin where I should have changed it to https://mywebsite/admin. I made the change during the install and everything is working as it should - Woohoo! Smile

Thanks so much for your help. It is greatly appreciated.

Best Regards,

Edgar

All times are EDT. The time is now 12:59 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content