Welcome to Geeklog Thursday, January 19 2017 @ 06:25 pm EST


 25/11/2011 04:11pm (Read 1273 times)  

Status: offline

drafty

Forum User

Junior
Registered: 05/09/2007
Posts: 16
I've recently switched server to PHP5 ... managed to resolve a few issues with website, but have just found this one. When I try to add photos to Media Gallery the error below comes up - although the pic does upload.
If I click on the RSS icon in the gallery I get an XML file - I've turned RSS off in Media Gallery settings and the RSS now seems to be appearing correctly.

Can someone please explain what I need to do to rectify this error .... many thanks in advance
PHP Formatted Code

An error has occurred:
2 - fopen(/home/users/uks59246/html/idhsgb.com/web/mediagallery/rss/mgmedia.rss) [function.fopen]: failed to open stream: Permission denied @ /home/users/uks59246/html/idhsgb.com/web/mediagallery/classes/feedcreator.class.php line 725
array(2) {
  ["filename"]=>
  string(69) "/home/users/uks59246/html/idhsgb.com/web/mediagallery/rss/mgmedia.rss"
  ["displayContents"]=>
  int(0)
}
(This text is only displayed to users in the group 'Root')

"Patience is never more important than when you're at the edge of losing it !!"

 26/11/2011 10:24am  

Status: offline

::Ben

Forum User

Full Member
Registered: 14/01/2005
Posts: 1566
Location:la rochelle, France
Hi,

You can try to create a empty mgmedia.rss file and put it in your mediagallery/rss folder.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

 27/11/2011 01:45pm  

Status: offline

drafty

Forum User

Junior
Registered: 05/09/2007
Posts: 16
Thanks Ben, tried this .... no difference !!

I've had a look at 'mediagallery/classes/feedcreator.class.php line 725' but cannot see anything to change ? Also all the .rss files in 'mediagallery/rss/' are numbered for the different galleries - i.e. mgmedia000001.rss'; etc .

Clicking the RSS icon in a gallery displays the XML file.

"Patience is never more important than when you're at the edge of losing it !!"

 27/11/2011 05:20pm  

Status: offline

::Ben

Forum User

Full Member
Registered: 14/01/2005
Posts: 1566
Location:la rochelle, France
What is your mediagallery version? Last available is Media Gallery WKZ 1.6.12.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

 28/11/2011 06:14am  

Status: offline

drafty

Forum User

Junior
Registered: 05/09/2007
Posts: 16
1.5.0 ... I appreciate it's not the latest, but everything was fine until the server change to PHP5
"Patience is never more important than when you're at the edge of losing it !!"

 28/11/2011 07:13am  

Status: offline

::Ben

Forum User

Full Member
Registered: 14/01/2005
Posts: 1566
Location:la rochelle, France
I suggest you to update the mediagallery plugin to take advantage of all the bug fixes and new features.

Also, according to Mark the plugin author:
This error is a permission issue. We need to make sure that the web server can write to the public_html/mediagallery/rss/ directory. So you'll either need to change the owner to the same user the web server is running as, or change permissions to allow full read / write access (777).


Ben
I'm available to customise your themes or plugins for your Geeklog CMS

 28/11/2011 07:39am  

Status: offline

drafty

Forum User

Junior
Registered: 05/09/2007
Posts: 16
Hi Ben
Thanks for this ....... I agree that perhaps updating may be my best option. I'll try read/write permissions first

many thanks
Dave
"Patience is never more important than when you're at the edge of losing it !!"

All times are EST. The time is now 06:25 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  • View Anonymous Posts 
  • Able to post 
  • Filtered HTML Allowed 
  • Censored Content