Welcome to Geeklog Friday, August 23 2019 @ 07:36 pm EDT

Geeklog Forums

upgrade issue


frawo

Anonymous
Hi

I have upgraded from 1.6 to 1.8, but version checker says 1.5.1.
Have tried four times, still same problem. Where to fix this?

And after upgrade I cannot use admin/configuration and admin/plugins (internal server error), the rest of admin is ok.
But I see that all the plugins have gone (menu: plugins (0), it used to be 4).

frawo

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1369
We will need more information like what web server you are using and any entries from your error log file.

I would also suggest switching to the professional theme that comes with Geeklog just untill we figure out your problems.

Tom
One of the Geeklog Core Developers.

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
I have upgraded from 1.6 to 1.8, but version checker says 1.5.1.

/public_html/siteconfig.php must be writable during the upgrade else it won't get updated w/ the new version.
And after upgrade I cannot use admin/configuration

GL1.8.x requires new theme updates to see this section, switch to the distributed professional theme as suggested.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

frawo

Anonymous
Hi

I had to manual change name:
.../layout/professional
to
.../layout/pure (default theme)

Then all ok.

But,
Changed then to purepro theme through menu, and no more site (internal server error).
Errorlog:
søn 11-09-2011 17:13:11 CEST - 1054: Unknown column 'created' in 'order clause'. SQL in question: SELECT pid,topic,is_open FROM gl_polltopics WHERE display = 1 ORDER BY created DESC
søn 11-09-2011 17:13:16 CEST - 1054: Unknown column 'created' in 'order clause'. SQL in question: SELECT pid,topic,is_open FROM gl_polltopics WHERE display = 1 ORDER BY created DESC


frawo

frawo

Anonymous
another error:
[Sun Sep 11 18:35:36 2011] [error] [client 82.146.86.191] FastCGI: comm with server "/hsphere/shared/php5/bin/php" aborted: error parsing headers: duplicate header 'Status'
[Sun Sep 11 18:35:41 2011] [error] [client 82.146.86.191] FastCGI: comm with server "/hsphere/shared/php5/bin/php" aborted: error parsing headers: duplicate header 'Status'


frawo

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Anonymous

søn 11-09-2011 17:13:11 CEST - 1054: Unknown column 'created' in 'order clause'. SQL in question: SELECT pid,topic,is_open FROM gl_polltopics WHERE display = 1 ORDER BY created DESC


Just checking: Did you run the upgrade (via the install script) or did you just upload the new files?

Also check in the admin's Plugins panel if any of the plugins report that they need to be upgraded. This should have been done by the install script during the upgrade but at least in this case it seems it didn't do it.

bye, Dirk

frawo

Anonymous
Hi

I did it through
.../admin/install/index.php

And it worked first time, updated the plugins through admin panel.

After I changed the theme from professional to purepro and put some files (gallery remote control) there too (deleted when problem started again), I cannot access. Tried fresh install again, but all I get is Internal server error again.

Why is not professional the default theme after a fresh upgrade?

frawo

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Anonymous

Why is not professional the default theme after a fresh upgrade?


Yeah, maybe we should do that.

You could try renaming your theme's directory (under public_html/layout) to something else and then rename the directory of the professional theme to the original name of your theme. That should at least get you a working theme again.

bye, Dirk

frawo

Anonymous
Hi

Upgraded to 1.8.1
Didn't put back the file siteconfig.php from backup, only db-config.php.
So far everything looks ok.
Will not yet try another theme for a while.

Thank for the help.

frawo

frawo

Anonymous
Hi

Upgraded to 1.8.1
Didn't put back the file siteconfig.php from backup, only db-config.php.
So far everything looks ok.
Will not yet try another theme for a while, seems to be some problems there (the already renamed professional to purepro turned out to be default in this upgrade)

Thanks for the help.

frawo

All times are EDT. The time is now 07:36 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content