Welcome to Geeklog Tuesday, July 07 2020 @ 08:43 am EDT

Geeklog Forums

Comment problem w/ v1.6.0sr2


Dan Dotson

Anonymous
When I try to enter a comment to a post (not in forum), 2 buttons appear at the bottom but neither has text or image to identify it. The HTML for the page has 2 entries like this <input type="submit" name="mode" value="">.
If I press either, I am taken to an error page that reports:
2 - array_merge() [function.array-merge]: Argument #2 is not an array @ /home5/yourfath/geekpersonal/system/lib-comment.php line 865
I am logged in as super user, if that matters.
Thanks for any help
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Is this a fresh install or an upgraded site?

In the latter case, make sure you've updated the language files.

bye, Dirk
 Quote

Dan Dotson

Anonymous
This is an update. I uploaded the entire package.
What do you mean by updating the language files?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Dan Dotson

This is an update. I uploaded the entire package.
What do you mean by updating the language files?


I meant to make sure you also updated the language files. You're seeing buttons without a text, so it sounds like your theme is up to date but your language files are not (the buttons use new texts not present in the language files of earlier Geeklog versions).

bye, Dirk
 Quote

Dan Dotson

Anonymous
embarrassed
I downloaded all the files from the site to a temporary folder on my PC then compared them to the 1.6.0sr2 package using WinMerge. To my surprise MANY files were older versions, suggesting the package did not properly transfer.
Subsequently, I transferred the package again and updated the site.
All seems fine now.
Thanks for your help!
 Quote

Dan Dotson

Anonymous
Well, I spoke too soon. My Error log is filling with these entries:
Sat 10 Oct 2009 13:39:16 MDT - Language "english" not found in $_CONF['language_files'] array!
I haven't seen a problem otherwise, but prefer not to have so many errors.
Ideas?
Thanks
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Sounds like you accidentally enabled multi-language support. Go to

Configuration > Geeklog > Languages and Locale > Language

and make sure both "Language Files" and "Languages" are disabled, i.e. click on the (X) if they show something other than the option to enable them.

bye, Dirk
 Quote

Dan Dotson

Anonymous
That change appears to work- no more entries in the error log.
Thank you!
 Quote

All times are EDT. The time is now 08:43 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content