Welcome to Geeklog Monday, July 15 2019 @ 08:07 pm EDT

Geeklog Forums

stainless_raven theme on Geeklog 1.60SR2


Status: offline

ryjguy7

Forum User
Newbie
Registered: 21/09/09
Posts: 1
Location:North Vancouver, B.C. , Canada
Hello,

I've setup a the stainless_raven theme on my new geeklog site. Being a newbie to website setup and config in general, my theme only works on the homepage. Any other link resorts back to the default theme of professional. I would like to enable the look of my new theme when all link are clicked on.

Any help would be greatly appriciated

thanks,

ryjguy7

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Hmm, that sounds odd. Where did you set your new theme? In the Configuration or under My Account? And does it change when you log into or out of your site?

bye, Dirk

ironmax

Anonymous
Dirk,

Its a theme that was most likely downloaded from geeklog.net and out of date (v1.4.1). I just installed it and making modifications to update it now. It should be ready for GL 1.6.x version soon.

Michael

Edit: Theme now updated and available from the Demo Site.

Ryan Letourneau

Anonymous
Yes I chose the theme option under the user preferences. I see now that the theme was only set to that specific user. I would like to make this theme the default for all, even guest users. So now I've move layout/professional aside to see what would happen. I only have stainless_raven in the layout dir now. But when I click on any links in the Admin Menu block, I get this; Template Error: set_root: /var/www/html/layout/professional is not a directory. Halted. So how does one tell the default config to user stainless_raven no matter what? In previous Geeklog versions there was just a general config.php, to set the default theme. In Geeklog 1.60SR2 it seems there are more than just config.php to set the default theme . . . maybe I will just change the name of the layout/stainless_raven folder to layout/professional . . . . .? ryjguy7

ironmax

Anonymous
Quote by: Ryan Letourneau

Yes I chose the theme option under the user preferences. I see now that the theme was only set to that specific user. I would like to make this theme the default for all, even guest users. So now I've move layout/professional aside to see what would happen. I only have stainless_raven in the layout dir now. But when I click on any links in the Admin Menu block, I get this;

Template Error: set_root: /var/www/html/layout/professional is not a directory.
Halted.

So how does one tell the default config to user stainless_raven no matter what? In previous Geeklog versions there was just a general config.php, to set the default theme. In Geeklog 1.60SR2 it seems there are more than just config.php to set the default theme . . . maybe I will just change the name of the layout/stainless_raven folder to layout/professional . . . . .?

ryjguy7



Put your Professional theme back in and then login as an admin. Then goto your configuration under Admin. Click on Theme on the left panel and then select Theme dropdown for the desired theme. Then click on save changes. At this point, if thats the only theme you want available you can either remove all the other themes in the layout directory or you can select Users and Submissions from the configuration again and select false from the Allow User Themes option. Then click on save.

by the way, did you upgrade that theme that was downloaded from the geeklog repository? That version is for geeklog 1.4.1 and does not have all the updates to run properly with geeklog v1.6.x. Go over to the demo site and grab an updated copy.

Michael

ryjguy7

Anonymous
o.k. . . I have another issue. I log in as Admin and if I select some of the options under Admin Menu I have to authorize three times, which is a good security measure . . but show the page as blank. Example I click on Admin Menu -> Configuration . . . then it shows the page with the left and right blocks, good, but shows just a blank white page in the centre, with no apparent options to edit the configuration. Help! . . . ryjguy7

ryjguy7

Anonymous
. . . also I installed the glmenu_3.1_1.5 plugin which is probablly not compatible with this version of Geeklog . . . but even the default install will not give me access to the Admin Menu -> Menu Admin . . . it always gives me an "Access Error - you don't have sufficient access" error message . . . but I am Admin?? Do I have to change privileges in a config file somewhere?? . . . ryjguy7

ironmax

Anonymous
Quote by: ryjguy7

o.k. . . I have another issue. I log in as Admin and if I select some of the options under Admin Menu I have to authorize three times, which is a good security measure . . but show the page as blank. Example I click on Admin Menu -> Configuration . . . then it shows the page with the left and right blocks, good, but shows just a blank white page in the centre, with no apparent options to edit the configuration. Help! . . .

ryjguy7



Well, logging in once should be sufficient. Did you update the theme files? When you click on "Admin Menu -> Configuration . . . then it shows the page with the left and right blocks", should not get that type of page. So something is wrong.

Look at your error.log file to see what happened.

I tried to register on your site to see what was happening, but no email was received as of yet!

Michael

ryjguy7

Anonymous
. . . I removed the stainless-raven dir and downloaded stainless-raven-V1_160 and put that in the layout dir . . . still does the same stuff thanks, ryjguy7

ironmax

Anonymous
Okay...if you have access to your database, go in with phpMyAdmin. Select the table named gl_plugins from the left side and then on the right side click on browse. Then scroll down to glmenu and click on the pencil only. A new screen will show the settings of that plugin. Then look about your 4th line entry down, it should say "pi_enabled tinyint(3) unsigned" and have a "1" in the box further alone. Change that to a "0" zero., and click save and Go on the bottom of that window.

Now try logging into your site and see if that worked...if it did, then there is something wrong with the install of the glMenu plugin.

Michael

ryjguy7

Anonymous
last entry from httpd error_log ; [Tue Sep 22 22:19:13 2009] [error] [client 216.26.202.140] File does not exist: /var/www/html/layout/professional/glmenu/cssmenu/images, referer: http://letourneau.home.dyndns.org/layout/professional/glmenu/cssmenu/blockmenu.css . . .

ryjguy7

Anonymous
. . . o.k I changed the entry in phpMyAdmin "pi_enabled tinyint(1) unsigned" "1" to "pi_enabled tinyint(1) unsigned" "0" and saved . . . now I go to my main page and I have a little error where the Admin Menu option used to be ; right under SITE MENU ; Error in PHP Block. Function, phpblock_glmenu, does not exist. ryjguy7

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Can't really help you with glMenu (try Blaine's site). But the login problems you have sound odd. Geeklog does not require you to log in several times - that's more of an indication that something is wrong.

Make sure your browser accepts cookies from your site. Also make sure you use a consistent domain name (either always with or without the www. part) when logging in. This somewhat outdated FAQ entry may also help (replace "config.php" with "Configuration" where it mentions that file ...).

bye, Dirk

ryjguy7

Anonymous
Is Geeklog 1.6.0sr2 an unstable beta release? If so, I should download the most Stable current version and install that . . . and absolutely make sure I download compatible plugins for the version I am using . . . it's all good just a little newbie inexperience to get over . . . ryjguy7

ironmax

Anonymous
Quote by: ryjguy7

Is Geeklog 1.6.0sr2 an unstable beta release? If so, I should download the most Stable current version and install that . . . and absolutely make sure I download compatible plugins for the version I am using . . . it's all good just a little newbie inexperience to get over . . .

ryjguy7



No...its not a beta release. Its a security release version and is working fine. Go into your blocks and turn off any block, by unchecking it, that had been created by glmenu. Either that, or uninstall the glmenu plugin. You should be back at where you started. Also keep in mind...if you had installed that plugin using one layout theme and switch to another theme...you will need to also copy the glmenu dir from that theme's dir, to all other themes. This might account for some of your problems.

Michael

All times are EDT. The time is now 08:07 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content