Welcome to Geeklog Tuesday, August 04 2020 @ 01:09 am EDT

Geeklog Forums

Media Gallery error-Please help


denis

Anonymous
I don't know how to fix this error and I don't know how to find this line 172.Can you highlighted this line 172 to show me that I can figure out which line is line 172?
PHP Formatted Code
<?php
// +---------------------------------------------------------------------------+
// | Media Gallery 1.2.0                                                       |
// +---------------------------------------------------------------------------+
// | classMedia.php                                                            |
// +---------------------------------------------------------------------------+
// | Copyright (C) 2005 by the following authors:                              |

(snipped)

?>


Can you fix it this issue for me ?

One my registered member on my website www.orahovica.org/ba uploaded one picture to My Album and now I have this huge error message:



An error has occurred:
2 - Division by zero @ /home/nine/public_html/ba/mediagallery/classMedia.php line 172

(snipped)

(This text is only displayed to users in the group 'Root'Wink
 Quote

mevans

Anonymous
This error is caused because one of the thumbnail images is missing. It looks like you are running version 1.2.0 which is very old. This problem was fixed long ago. I recommend that you upgrade to v1.5.0 which is the latest version.

Thanks!
Mark
 Quote

denis

Anonymous
Can you tell me how can I fix this error ?
Need I first fix this error and then make upgrade to newest version?
How can I make this upgrade and transfer all pictures to new album?
 Quote

Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
P L E A S E

tell me how can i fix this error...

Please,please :banghead: :banghead: :banghead:
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Mark already answered your question above: You need to upgrade Media Gallery. Download the new version and follow the instructions ...

bye, Dirk
 Quote

Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
Dirk...thank you for nothing...
If i can solve my issue all by my self,be sure that i will not asking somebody for help on this forum..
Downloading , installing and upgrading new media gallery sometimes is not so easy in cause of some errors.

Must be some way that i can fix this error and keep this media gallery version ...
Can somebody be helpful here?
 Quote

Status: offline

jmucchiello

Forum User
Full Member
Registered: 29/08/05
Posts: 985
The author of the plugin told you to upgrade the plugin. That is the fix. He fixed the bug you have back in 2006. You are asking him to look at 2 year old code that is 30+ releases out of date. Asking you to upgrade is not unreasonable.
 Quote

All times are EDT. The time is now 01:09 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content