Welcome to Geeklog, Anonymous Thursday, September 29 2022 @ 12:59 am EDT

Geeklog Forums

Url rewrite in config Error


Status: offline

linker

Forum User
Newbie
Registered: 03/03/07
Posts: 7
Hi I am using apache and linux server. from godaddy My safe_mode in off I have turned on the url_rewrite to true in the config file Yet i am getting a 404 error on all my article pages PLEASE HELP. I am desperate. My website is http://huntsvillepr.com
 Quote

Status: offline

jmucchiello

Forum User
Full Member
Registered: 08/29/05
Posts: 985
You also have to add rewrite rules to your .htaccess file for the rewrites to work. And, no, there are no example files that I know of.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: linker

Yet i am getting a 404 error on all my article pages


I don't see a 404 but a "No input file specified." message.

Which Geeklog version is that? This sounds like a problem that has long been fixed.

And, despite what Joe said, you don't need any additional rules in your .htaccess.

bye, Dirk
 Quote

Linker

Anonymous
I have a .htaccess file in place which has changed my topics from dynamic to static. Here it is. Perhaps this could be of help to others RewriteBase / RewriteEngine on Options +FollowSymlinks RewriteRule ^business/$ /index.php?topic=business [NC,L] RewriteRule ^opening/$ /index.php?topic=opening [NC,L] RewriteRule ^engineering/$ /index.php?topic=engineering [NC,L] RewriteRule ^featured/$ /index.php?topic=featured [NC,L] RewriteRule ^realestate/$ /index.php?topic=realestate [NC,L] RewriteRule ^general/$ /index.php?topic=general [NC,L] RewriteRule ^health/$ /index.php?topic=health [NC,L] RewriteRule ^taxes/$ /index.php?topic=20070110203029399 [NC,L] RewriteRule ^article.php/$ /article.php?story= [NC,L] The problem is that the search engine friendly URL ( for stories / articles ) created by switching to true in the config file is not working. When i click on my articles i get a 404 error message. It seem to me that i have all my variable in place - i have gone through the to do list re rewrite rules and this is still not working. Where else could i have made a mistake? any other suggestion
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
To repeat what I already wrote above: When I go to one of your stories, I don't get a 404 but a "No input file specified". Which Geeklog version are you using?

bye, Dirk
 Quote

Linker

Anonymous
I appreciate all the help. I am using version 1.4 To prove that i am getting a 404 error please try this link, which is the last article posted http://huntsvillepr.com/article.php/2007042920470379. Thank again. Do not give up on me...
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Linker

ITo prove that i am getting a 404 error please try this link, which is the last article posted

http://huntsvillepr.com/article.php/2007042920470379.


As with all your other articles, I get a
No input file specified.

bye, Dirk
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Ah, that message comes with a 404 status code.

You could try replacing your system/classes/url.class.php with the file from Geeklog 1.4.1 and see if that makes a difference.

bye, Dirk
 Quote

Linker

Anonymous
I have downloaded the version 1.41 and replace the systems/classes/url.class.php as you suggested, but this did not work.

What could i have done wrong? Could it be something with godaddy?
 Quote

ironmax

Anonymous
Just out of curiosity, do you have anything in your error log file that might give a clue to this? Also, if you have access, check your php error log as well. That log name should be listed in the php.ini file, again if you have access to it.

Text Formatted Code

PHP.INI file

; Log errors into a log file (server-specific log, stderr, or error_log (below))
; As stated above, you're strongly advised to use error logging in place of
; error displaying on production web sites.
log_errors = On

; Log errors to specified file.
error_log = /what/ever/path/you/want/to/errors.log

 


 Quote

Linker

Anonymous
Thanks again for your answers

I have checked the log errors and it is mainly made up of

302 trackback verification errors.

I have seen nothing related to the 404 that i received

What else could it be? Could it have something to do with Chmod?

Could it be something with Godaddy?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
The trackback verification notices are spamming attempts and have nothing to do with the problem.

Yes, I believe this is a problem with the server setup, so try contacting your hosting service support. If they are running Apache 2.x, point them to item #3 in the FAQ entry on url rewriting (and note that this has nothing to do with Apache's mod_rewrite module - Geeklog's rewriting is implemented in PHP and relies on the PATH_INFO environment variable, provided by the webserver and PHP).

bye, Dirk
 Quote

Linker

Anonymous
I have called Godaddy and this is the situation.

1) My hosting is on PHP Version 4.3.11
2) The server Apache 1.3.33
3) Here is what is written on my php.info file:

safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir ~ ~

4) This is what is written in Godaddy's help area:
PHP 4
We do not disable any PHP 4 functions on our Linux hosting accounts.

PHP 5
The PHP 5 function register_globals is turned off by default.

I was told that changes to php.ini can only be done with a dedicated server



 Quote

Status: offline

jmucchiello

Forum User
Full Member
Registered: 08/29/05
Posts: 985
Are you sure they have mod_rewrite activated in Apache?
 Quote

Linker

Anonymous
Yes, i believe so In fact my menu items (located in the upper left hand column )in http://huntsvillepr.com are mod_rewrite urls
 Quote

Linker

Anonymous
I ask them and they said that mod_rewrite is on
 Quote

All times are EDT. The time is now 12:59 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content