Welcome to Geeklog, Anonymous Sunday, November 27 2022 @ 11:16 pm EST

Geeklog Forums

Unfortunately, an error has occurred rendering this page. Please try again later.


Jamie

Anonymous
I don't get this. I checked other threads with the same issue and it says it has to do with a wrong path in lib-common.php but I'm positive my path is correct to the config file.


My path to the public_html is: /home/jessica/public_html/
My path to config is /home/jessica/

I just don't get why its working. In lib-common I changed the require once path to /home/jessica/config.php and I keep getting this error.

I also tried changing the error handler to true and it didn't show up any new errors.

Any ideas?
 Quote

Jamie

Anonymous
I should also add, I can view the admin panel, the initial one where you have to click on the story link to find out how to login to the admin panel, but as soon as I click on something, I get that error :-/
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 08/04/03
Posts: 1298
Maybe check the settings in config.php again? Anything special? $_CONF['site_url'] withouth trailing slash?
 Quote

Jamie

Anonymous
I've tried the site url with the trailing slash and without. When I click on a link, and get that error, there is an extra "/" though.. it looks like:

http://mysite.com/geeklog//index.php but I can't figure out how to get rid of it or how to tell if that is even the problem.
 Quote

Jamie

Anonymous
Grr that's not it either. I got rid of the extra "/" but I still get the same error... :-/
 Quote

Jamie

Anonymous
Interesting, you can view this file and others as long as it has nothing to do with index.php

http://jessicaharp.org/admin/directory.php?topic=all
 Quote

Status: offline

jmucchiello

Forum User
Full Member
Registered: 08/29/05
Posts: 985
Quote by: Jamie

I've tried the site url with the trailing slash and without. When I click on a link, and get that error, there is an extra "/" though.. it looks like:

http://mysite.com/geeklog//index.php but I can't figure out how to get rid of it or how to tell if that is even the problem.


My path to the public_html is: /home/jessica/public_html/
My path to config is /home/jessica/

So your webserver is setup so that http://mysite.cm/geeklog is a virtual directory pointing to /home/jessica/public_html? I find that unusual at a minimum. Are you sure you shouldn't be using http://mysite.com/index.php tto access the site? Or some other combination of the paths?
 Quote

scott

Anonymous
I get the same error message, it happens every single time I try to access a PHP file through my browser. It's starting to get really annoying, I've checked paths and everything loads. I've even managed to install it, create databases but can't get any further than the success page.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
It's really time for an FAQ article ...

First of all, try setting $_CONF['rootdebug'] = true; in your config.php and see if that provides any more information (and don't forget to set it back to = false once the problem is resolved).

Also make sure you've changed the require_once line in lib-common.php to include your config.php there.

bye, Dirk
 Quote

scott

Anonymous
Thanks for the help, I sorted out the problem.

However for some reason when the installation finishes I get a 'template error' message now with

home/dir/folder/home/dir/folder/templates/professional

Obviously with the correct names. I don't understand why it's trying to look there, because it doesn't exist. If you take out the first "home/dir/folder" then it's a valid directory. What do I alter for that?

Thanks again for the help so far, sorry if these are basic questions!
 Quote

scott

Anonymous
Forget it, I figured out what I was doing wrong!

Thanks again for helping me get this going!

I'm still clueless as to how I can make this part of my site though, with my own backgrounds and stuff. That geeklog page is now my homepage, which was't what I wanted...

Again, apologies for being dense!

www.themusicmagazine.co.uk
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
:rtfm: http://www.geeklog.net/docs/install.html#template-error

Also make sure that all your paths are absolute, i.e. start with a /

bye, Dirk
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: scott

I'm still clueless as to how I can make this part of my site though, with my own backgrounds and stuff. That geeklog page is now my homepage, which was't what I wanted...


Then what is it what you want?

And maybe you could start a new thread for that, instead of hijacking someone else's, because your posts probably didn't really help the original poster with their problem ...

bye, Dirk
 Quote

scott

Anonymous
I apologise, I'd forgotten all about that.

Never mind, after all that I've decided this isn't for me. I daresay there are easier ways than this!

Thanks again for all the help, sorry to waste your time and patience.
 Quote

Jamie

Anonymous
Quote by: Dirk

It's really time for an FAQ article ...

First of all, try setting $_CONF['rootdebug'] = true; in your config.php and see if that provides any more information (and don't forget to set it back to = false once the problem is resolved).

Also make sure you've changed the require_once line in lib-common.php to include your config.php there.

bye, Dirk



I have done all of this. AS I SAID, if you go to to article.php or index.php I get the error but the other files seem to be fine.
 Quote

Jamie

Anonymous
FINALLY solved.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Jamie

FINALLY solved.


What was it then?

bye, Dirk
 Quote

All times are EST. The time is now 11:16 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content